Bug 821213 - Nepomuk cannot index most pdf files.
Nepomuk cannot index most pdf files.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: strigi (Show other bugs)
16
i386 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Deji Akingunola
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-13 03:34 EDT by addammo
Modified: 2012-07-12 13:00 EDT (History)
10 users (show)

See Also:
Fixed In Version: strigi-0.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-12 13:00:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pdf for testing (17.39 KB, application/pdf)
2012-05-13 03:34 EDT, addammo
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 231936 None None None Never

  None (edit)
Description addammo 2012-05-13 03:34:10 EDT
Created attachment 584109 [details]
pdf for testing

Description of problem: most pdf files are not indexed. Since version 4.7.3 nepomuk uses pdttotext to index pdf files.


Version-Release number of selected component (if applicable):
4.7.4

How reproducible:
Always

Steps to Reproduce:
1. Save the joined file somewhare into a directory indexed by nepomuk/strigi;
2. 
3.
  
Actual results:
File not indexed by nepomuk

Expected results:
File indexed by nepomuk

Additional info:
I read a discussion about this issue here:
https://bugs.kde.org/show_bug.cgi?id=231936

But, does the patch really works?

I join a sample pdf file.
Comment 1 addammo 2012-05-13 03:36:56 EDT
The program pdftotext works with the file i joined.
Comment 2 Martin Bříza 2012-07-12 10:36:28 EDT
Hello,
the upstream (in the external tracker) bug claims the issue to be fixed in KDE 4.7.3 with strigi 0.7.7. What versions did you test, please? Is the bug still present?
There are some reports on the upstream Bugzilla that the bug wasn't fixed entirely. If you still do experience the problems, please let us and upstream know.
Thank you.
Comment 3 addammo 2012-07-12 10:51:18 EDT
(In reply to comment #2)
> Hello,
> the upstream (in the external tracker) bug claims the issue to be fixed in
> KDE 4.7.3 with strigi 0.7.7. What versions did you test, please? Is the bug
> still present?
> There are some reports on the upstream Bugzilla that the bug wasn't fixed
> entirely. If you still do experience the problems, please let us and
> upstream know.
> Thank you.

Yes, I updated strigi to version 0.7.7 and now pdf files are indexed. I forgot to update my info here, sorry. You can close this bug.

Note You need to log in before you can comment on or make changes to this bug.