Bug 821237 - [CUPS usb] Canon PIXMA MP280 doesn't work
[CUPS usb] Canon PIXMA MP280 doesn't work
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: sane-backends (Show other bugs)
16
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-13 08:47 EDT by Alexei Panov
Modified: 2013-02-13 14:38 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-13 14:38:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
CUPS log file with debug option enabled (466.57 KB, text/x-log)
2012-05-13 08:47 EDT, Alexei Panov
no flags Details
troubleshoot.txt from MP280 (140.19 KB, text/plain)
2012-09-19 11:50 EDT, rumijah
no flags Details

  None (edit)
Description Alexei Panov 2012-05-13 08:47:38 EDT
Created attachment 584137 [details]
CUPS log file with debug option enabled

Description of problem:
I've connected multifunction device Canon PIXMA MP280, set it up over the cups (localhost:631). Selected driver - gutenprint.
Then I tried to print test page. For a short time, device shows that it started to work with the data, but then nothing happens. From other application printer doesn't print too.

Version-Release number of selected component (if applicable):
cups-1.5.2-9.fc16.i686
gutenprint-5.2.7-7.fc16.i686
gutenprint-cups-5.2.7-7.fc16.i686

How reproducible:
any time, in Fedora 17 too

Steps to Reproduce:
1. Connect multifunction device Canon PIXMA MP280
2. setup it
3. try print test page
  
Actual results:
Device doesn't print

Expected results:
Device will print correctly.
Comment 1 Jiri Popelka 2012-05-14 06:45:03 EDT
I see some warnings scattered across the log, like:
D [12/May/2012:19:22:33 +0600] [CGI] /usr/share/cups/drivers/pscript5.dll: Нет такого файла или каталога (No such file or directory)
E [12/May/2012:19:22:36 +0600] [CGI] Saw EOF, expected '}'!
D [12/May/2012:19:25:17 +0600] Get-Printer-Attributes client-error-not-found: The printer or class does not exist.

But the print job itself seems to be done with no errors:
D [12/May/2012:19:25:26 +0600] [Job 1] Gutenprint: Done printing page 1
D [12/May/2012:19:25:26 +0600] [Job 1] Gutenprint: Ending job
D [12/May/2012:19:25:26 +0600] PID 2145 (/usr/lib/cups/filter/gstoraster) exited with no errors.
D [12/May/2012:19:25:26 +0600] PID 2146 (/usr/lib/cups/filter/rastertogutenprint.5.2) exited with no errors.
D [12/May/2012:19:25:26 +0600] PID 2147 (/usr/lib/cups/backend/usb) exited with no errors.
Comment 2 Jiri Popelka 2012-05-14 07:30:44 EDT
Seems similar to bug #771234.
Comment 3 rumijah 2012-09-11 10:19:24 EDT
I have had similar problems with MP280 after updating to F17.
Printer & scanner worked with F16. 

Got printer working by following advice at Bug 847923: 
"yum downgrade cups cups-libs" to 1.5.2 

Note: the advice to update it with:
# su -c 'yum update --enablerepo=updates-testing cups-1.5.4-3.fc18'

did not work.

Still cannot get scanner to work with F17...
& yes, I have the newest version of scangearmp ...
Comment 4 Jiri Popelka 2012-09-19 06:10:03 EDT
rumijah, you may see bug #854989
Can you try this build ?
https://koji.fedoraproject.org/koji/buildinfo?buildID=354948

If it doesn't fix it please attach output from printing troubleshooter
https://fedoraproject.org/wiki/Printing/Debugging#Printing_troubleshooter
Comment 5 rumijah 2012-09-19 11:50:01 EDT
Created attachment 614431 [details]
troubleshoot.txt from MP280


Attached is “troubleshoot.txt” from my Canon MP280 
in response to Comment #4 from Jiri Popelka:
********************************

Tried to install: cups-libs-1.5.4-3.fc17.i686.rpm
and I got the error message:
1:cups-1.5.4-2.fc17.i686 requires cups-libs(x86-32) = 1:1.5.4-2.fc17
********************************
I then updated to: 

cups-libs-1:1.5.4-2.fc17 (32-bit)
cups-1:1.5.4-2.fc17 (32-bit)

and my Canon MP280 now prints ok (in portrait mode -- doesn't work in landscape mode).
********************************
Tried to install: cups-libs-1.5.4-3.fc17.i686.rpm
and (again) I got the error message:
1:cups-1.5.4-2.fc17.i686 requires cups-libs(x86-32) = 1:1.5.4-2.fc17

********************************
By the way, I got the scanner working by following the instructions here: 

http://forums.linuxmint.com/viewtopic.php?f=42&t=76930 

Open a terminal window and run lsusb. Here's what my output looked like. Yours should be similar.

UserName@computer ~ $ lsusb

Bus 001 Device 005: ID 04a9:1746 Canon, Inc.


The file to edit is: /lib/udev/rules.d/65-libsane.rules

I used Nautilus to navigate to the system area and opened the folder /lib/udev/rules.d by right-clicking on it and selecting "Open as administrator" from the drop down menu. Then find the file 65-libsane.rules, double-click it to open it in a gedit text editor window. There's a long list of printers. There was no mention of the MP280 in my copy of this file. I scrolled down and copied the two lines for the PIXMA 270, opened up a space, and pasted them in. Then I edited the line to look like the two lines below that refer to the PIXMA 280. In my case, only the name of the device and the number "1746" had to be edited. Those four digits make a big difference.


# Canon PIXMA MX330
ATTRS{idVendor}=="04a9", ATTRS{idProduct}=="1737", ENV{libsane_matched}="yes"
# Canon PIXMA MP250
ATTRS{idVendor}=="04a9", ATTRS{idProduct}=="173a", ENV{libsane_matched}="yes"
# Canon PIXMA MP270
ATTRS{idVendor}=="04a9", ATTRS{idProduct}=="173b", ENV{libsane_matched}="yes"
 Canon PIXMA MP280
ATTRS{idVendor}=="04a9", ATTRS{idProduct}=="1746", ENV{libsane_matched}="yes"
# Canon PIXMA MP490
ATTRS{idVendor}=="04a9", ATTRS{idProduct}=="173c", ENV{libsane_matched}="yes"


scanner now works when I enter “scangearmp” in the terminal...

Thanks for the help.
Comment 6 Tim Waugh 2012-09-20 06:52:58 EDT
Nils, looks like the MP280 line needs to be added...
Comment 7 Fedora End Of Life 2013-01-16 11:12:13 EST
This message is a reminder that Fedora 16 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 16. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '16'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 16's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 16 is end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" and open it against that version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Fedora End Of Life 2013-02-13 14:38:51 EST
Fedora 16 changed to end-of-life (EOL) status on 2013-02-12. Fedora 16 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.