Bug 821275 - resume from suspend sometimes fails on Thinkpad W520
resume from suspend sometimes fails on Thinkpad W520
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
17
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-13 15:56 EDT by patrick korsnick
Modified: 2013-08-01 12:22 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-01 12:21:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description patrick korsnick 2012-05-13 15:56:30 EDT
Description of problem:

This is a very peculiar problem. I have a f17 Gnome install and it seems the first suspend/resume cycle works fine, but the following ones will not resume correctly. I usually get 1 of 2 behaviors:

I either see a black screen with the G3 menu bar at the top, but no box that prompts for password. Mouse cursor moves with the mouse. Typing password and hitting enter repeatedly doesn't work. Alt F2 can get a virtual console. I can kill X with ctrl-alt-bksp and gdm will let me log in again.

Or I get a screen of garbled black and white- can't get a virtual console. ctrl-alt-bksp, ctrl-alt-del don't do anything. At this point I have to hold down the power button to kill the box.

I am running stock f17 install with the nouveau driver. Machine is in 'discrete graphics' mode in BIOS, meaning only the nvidia card (quadro 1000) is active.

I have 2 other stock f17 installs on this box - one KDE and one Xfce. I will attempt to recreate the problem there and see if it affects them as well.

Version-Release number of selected component (if applicable):

17

How reproducible:

every time

Steps to Reproduce:
1. suspend/resume box
2. wait a bit and try it again
3.
  
Actual results:

described above 

Expected results:

suspend/resume to work properly

Additional info:
Comment 1 patrick korsnick 2012-05-13 16:04:31 EDT
After more testing I found that you have to click suspend from the menu and then close the laptop lid to produce the first behavior- can see the menu bar and mouse moves, just can't log in.

If you just click the suspend button and leave the lid open, a subsequent press of the power button will resume the machine properly.

Perhaps the lid close event and suspend event are stepping on each other. If this is the case then I'd say it's a reason that Gnome 3 should let you configure the lid close behavior because there is no other way that I know of to suspend the machine when you close the lid and have an external display attached.
Comment 2 Vic Ricker 2012-06-12 21:51:38 EDT
As far as I can tell, suspend on lid-close is broken in F17.  acpi_listen reports the lid open/close events, but my laptop does not suspend when the lid is closed.


I have not seen the behavior that you mentioned.  Since the lid close is broken, I have been using the menu suspend option, which seems to work fine so far.  I primarily use the MATE desktop.  I thought that might be causing the problem, so I tried in Gnome shell.  It behaves the same.  Both are set to suspend when the lid closes.  (I'm using gnome-tweak-tool with gnome 3.)

Do you wait for it to suspend fully before closing the lid?

I'm using the proprietary nVidia driver.  I'm not sure if that might have something to do with it.
Comment 3 patrick korsnick 2012-06-13 15:38:57 EDT
Vic, I'm using the nouveau driver and suspend/resume on lid close and open works as expected if there's no external display connected. If a display is connected, then it shifts the main display to the external display and doesn't sleep despite what you have set in gnome-tweak-tool. This is the behavior defined by Gnome 3 I'm told.

I think you nailed it when you said you have to wait until it is full asleep when you click 'suspend' before you close the lid. If I do that suspend/resume works fine. It's only when I click suspend and then shut the lid right away that it fails.
Comment 4 patrick korsnick 2012-06-13 15:45:13 EDT
I see two possible fixes for this problem--

The first would be to examine the interaction between the suspend event and closing the lid and making it more robust so that I doesn't blow up if those two actions are done in what would be considered a 'normal' succession- one clicks suspend and then closes the lid. I think it's abnormal to force the user to have to wait for 10 seconds or so until the machine is asleep before they are allowed to close the lid.

The second would be to to modify Gnome 3 to not override the users setting (in gnome-tweak-tool) for Lid close behavior if a monitor is connected.
Comment 5 Vic Ricker 2012-06-22 19:26:36 EDT
Switching to mdm solved my problem:

http://forums.mate-desktop.org/viewtopic.php?f=8&t=334

Good luck with Gnome 3.
Comment 6 Josh Boyer 2012-07-10 13:08:54 EDT
If suspend is working one way or another, it seems this isn't a kernel issue.  Are you still having this issue with the latest F17 updates?  If so, perhaps you can reassign to something in gnome?
Comment 7 patrick korsnick 2012-07-11 00:06:48 EDT
(In reply to comment #6)
> If suspend is working one way or another, it seems this isn't a kernel
> issue.  Are you still having this issue with the latest F17 updates?  If so,
> perhaps you can reassign to something in gnome?

Yes I agree this shouldn't belong to kernel- will reassign to gnome-shell.
Comment 8 Fedora End Of Life 2013-07-04 01:20:34 EDT
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 9 Fedora End Of Life 2013-08-01 12:22:00 EDT
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.