Bug 821276 - gwenview when at 100% zoom returns to "zoom to fit" when going to next picture
gwenview when at 100% zoom returns to "zoom to fit" when going to next picture
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gwenview (Show other bugs)
16
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-13 16:28 EDT by Aythya
Modified: 2016-04-01 05:58 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-12 11:25:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 291759 None None None 2012-07-12 11:25:11 EDT

  None (edit)
Description Aythya 2012-05-13 16:28:45 EDT
Description of problem:

gwenview 4.8.3 when switched to 100% zoom does not remain in the same zoom level when going to the next picture in the folder, instead the next picture is shown in the "fit to screen" mode. Worked fine in version 4.7.4


Version-Release number of selected component (if applicable):

4.8.3

How reproducible:
view a picture, click 100% zoom, go to next picture in the same folder, the next picture is now fitted to screen instead of 100% zoom as the previous picture


Steps to Reproduce:
1. browse a folder containing several pictures
2. double click one picture
3. click 100% zoom 
4. go to next picture in the folder (PgDn or other assigned key)
  
Actual results:

The next picture is fitted to screen


Expected results:

The following pictures should show at the same zoom level as the previous picture (100% in this case). Or, at least, there should be an option to choose which is the default behavior.

Additional info:

Worked fine with gwenview version 4.7.4. Staying at the same zoom level is useful when comparing several shots of the same scene (e.g. when checking sharpness).
Comment 1 Martin Bříza 2012-07-12 11:25:11 EDT
Hello,
this bug will be fixed in KDE SC 4.9 as the external tracker says. Unfortunately, the fix can't be backported without major changes to the component, so please upgrade your system when 4.9 is available.
Thank you for reporting.
Comment 2 Mark van Rossum 2016-04-01 05:58:03 EDT
Note (to self): this is now fixed, but 'enlarge smaller images' has to be set in the options.

Note You need to log in before you can comment on or make changes to this bug.