Bug 821282 - [abrt] xscreensaver-base-5.15-3.fc16: kill: Process /usr/bin/xscreensaver was killed by signal 6 (SIGABRT)
[abrt] xscreensaver-base-5.15-3.fc16: kill: Process /usr/bin/xscreensaver was...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xscreensaver (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mamoru TASAKA
Fedora Extras Quality Assurance
abrt_hash:e336f2cfad7ed8940e0eadc6241...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-13 18:41 EDT by Aurelio Calegari
Modified: 2012-05-16 21:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-16 21:01:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: event_log (9.86 KB, text/plain)
2012-05-13 18:41 EDT, Aurelio Calegari
no flags Details
File: backtrace (17.18 KB, text/plain)
2012-05-13 18:42 EDT, Aurelio Calegari
no flags Details
File: coredump (1.30 MB, text/plain)
2012-05-13 18:42 EDT, Aurelio Calegari
no flags Details
File: maps (13.46 KB, text/plain)
2012-05-13 18:42 EDT, Aurelio Calegari
no flags Details

  None (edit)
Description Aurelio Calegari 2012-05-13 18:41:52 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        xscreensaver -no-splash
comment:        I have left the box for the day, locked. When I returned I verified the screen saver has crashed
crash_function: kill
executable:     /usr/bin/xscreensaver
kernel:         3.3.4-3.fc16.x86_64
pid:            2617
pwd:            /home/aurelica
reason:         Process /usr/bin/xscreensaver was killed by signal 6 (SIGABRT)
time:           Sat 12 May 2012 10:35:27 AM EST
uid:            1000
username:       aurelica
var_log_messages: May 12 10:35:28 its27940 abrt[12230]: Saved core dump of pid 2617 (/usr/bin/xscreensaver) to /var/spool/abrt/ccpp-2012-05-12-10:35:27-2617 (1368064 bytes)

backtrace:      Text file, 17588 bytes
event_log:      Text file, 10096 bytes
maps:           Text file, 13783 bytes

build_ids:
:7343d35696ce251688ece0a26e457e61ca805cfd
:28579c89bda7f08dace218884d7a5561f3f5f89d
:dc998e8c1e1dc44c684b9b86e753945a868e134a
:aaf7ed41612348bd1141db06cadd428244aa6ea5
:cab89b532dc6597e57a4abb0252070aa587b97cd
:578e66700318d8cec8e5f03778c434743a55e153
:e3c88cb9ea428bd61f4064dbd53acae2d396a1ec
:1c6a95451ee19617be5abea3d121f0226d21ddda
:d0c6e13f00a20952a72a945c929efb175fd760e3
:a594ab36356a9b6dc6ecf25a6124463ccbfd0a29
:5a491e02e37595592ec20c9c8c17442a46d8ddc6
:638db099ff5fb986d1a092629d1bb1dca5be4904
:dacf32a9a2f2b5077ba944e7b835cca6f637f78f
:25b834f4c4dc534708635ff1064e2fe02a366a62
:163b323da65b708418226eb5fa8b057c731d1475
:e2e67b3ae2579e1667b73ad385f61552931024e9
:7994f114cf7189e482f2665fae8e351ed8bc05e3
:b1f637567bf1f02234c9c02e1a7fd2d2335b3b31
:40dc5e32f96a3d6d6728301becc415c9af4a68bb
:4953d1f613914126bccceb3cb96386647ffba9df
:2639b5594fe4d7897db63ecd1ebb9681438317a8
:4c842320387ff7f6f91b7842b223c16518be909f
:0d039828591f6fe108db1d5458ca340cbfc4ff6d
:75eaece6e0d1e075520cdfad5c398fdab4370846
:0911ea7c180d733724f89037b8e8a34e64024aec
:be507c791e34415e8f42f0e6030c889b2895cf9a
:14063d4a97bae5e96c07a1a7c0e6ca5c982839f3
:3bbe4d98714c66cda2944cd39900eea5d348df18
:e2d68a0ee0872365dcc8c6640b7cd7b94c8276f2
:b9d3a4213a482d034bebc7dc1ed2901a734a894d
:6c549ce52cda735c1f4fdfda714f39ab6685c155
:7a896ce784b97721d1f6960bfba25e60511c0178
:c2d49d72ec1a1e68b39c3724693f83f44d80a259
:2670385f49fb9f120f7cf843f211e3c620da8632
:1a212c7f1515542b310ba92f6109efc9b5bf2b6e
:11e343f1da2a0c5c61502657909b8c4fe5e21b72

dso_list:
:/usr/lib64/libXcursor.so.1.0.2 libXcursor-1.1.11-3.fc15.x86_64 (Fedora Project) 1320287307
:/usr/lib64/libXrender.so.1.3.0 libXrender-0.9.6-2.fc15.x86_64 (Fedora Project) 1320287306
:/usr/lib64/libxcb.so.1.1.0 libxcb-1.7-3.fc16.x86_64 (Fedora Project) 1320287306
:/lib64/libfreebl3.so nss-softokn-freebl-3.13.4-1.fc16.x86_64 (Fedora Project) 1334797637
:/usr/lib64/libffi.so.5.0.10 libffi-3.0.10-1.fc16.x86_64 (Fedora Project) 1320287305
:/usr/lib64/libX11.so.6.3.0 libX11-1.4.3-1.fc16.x86_64 (Fedora Project) 1320287306
:/usr/lib64/libSM.so.6.0.1 libSM-1.2.0-2.fc15.x86_64 (Fedora Project) 1320287305
:/usr/lib64/libXinerama.so.1.0.0 libXinerama-1.1.1-2.fc15.x86_64 (Fedora Project) 1320287307
:/lib64/libpthread-2.14.90.so glibc-2.14.90-24.fc16.6.x86_64 (Fedora Project) 1334015345
:/usr/lib64/libXfixes.so.3.1.0 libXfixes-5.0-1.fc16.x86_64 (Fedora Project) 1320287306
:/lib64/libglib-2.0.so.0.3000.3 glib2-2.30.3-1.fc16.x86_64 (Fedora Project) 1336610601
:/lib64/libcrypt-2.14.90.so glibc-2.14.90-24.fc16.6.x86_64 (Fedora Project) 1334015345
:/lib64/libgobject-2.0.so.0.3000.3 glib2-2.30.3-1.fc16.x86_64 (Fedora Project) 1336610601
:/usr/lib64/libXxf86misc.so.1.1.0 libXxf86misc-1.0.3-2.fc15.x86_64 (Fedora Project) 1320287310
:/lib64/libdbus-1.so.3.5.6 dbus-libs-1:1.4.10-3.fc16.x86_64 (Fedora Project) 1320287304
:/lib64/libdl-2.14.90.so glibc-2.14.90-24.fc16.6.x86_64 (Fedora Project) 1334015345
:/lib64/libuuid.so.1.3.0 libuuid-2.20.1-2.3.fc16.x86_64 (Fedora Project) 1336610611
:/lib64/libc-2.14.90.so glibc-2.14.90-24.fc16.6.x86_64 (Fedora Project) 1334015345
:/lib64/librt-2.14.90.so glibc-2.14.90-24.fc16.6.x86_64 (Fedora Project) 1334015345
:/usr/lib64/libICE.so.6.3.0 libICE-1.0.7-1.fc16.x86_64 (Fedora Project) 1320287304
:/usr/lib64/libXxf86vm.so.1.0.0 libXxf86vm-1.1.1-2.fc15.x86_64 (Fedora Project) 1320287308
:/usr/lib64/libXau.so.6.0.0 libXau-1.0.6-2.fc15.x86_64 (Fedora Project) 1320287306
:/lib64/libgcc_s-4.6.3-20120306.so.1 libgcc-4.6.3-2.fc16.x86_64 (Fedora Project) 1334015339
:/usr/lib64/libXrandr.so.2.2.0 libXrandr-1.3.1-2.fc15.x86_64 (Fedora Project) 1320287306
:/lib64/ld-2.14.90.so glibc-2.14.90-24.fc16.6.x86_64 (Fedora Project) 1334015345
:/usr/lib64/libXext.so.6.4.0 libXext-1.3.0-1.fc16.x86_64 (Fedora Project) 1334119898
:/usr/lib/locale/locale-archive glibc-common-2.14.90-24.fc16.6.x86_64 (Fedora Project) 1334015351
:/lib64/libgthread-2.0.so.0.3000.3 glib2-2.30.3-1.fc16.x86_64 (Fedora Project) 1336610601
:/lib64/libaudit.so.1.0.0 audit-libs-2.2.1-1.fc16.x86_64 (Fedora Project) 1334615951
:/usr/lib64/libdbus-glib-1.so.2.1.0 dbus-glib-0.92-2.fc15.x86_64 (Fedora Project) 1320287306
:/lib64/security/pam_fprintd.so fprintd-pam-0.4.1-1.fc16.x86_64 (Fedora Project) 1334120440
:/usr/lib64/libXt.so.6.0.0 libXt-1.1.1-1.fc16.x86_64 (Fedora Project) 1320287307
:/lib64/libnss_files-2.14.90.so glibc-2.14.90-24.fc16.6.x86_64 (Fedora Project) 1334015345
:/usr/lib64/libXmu.so.6.2.0 libXmu-1.1.0-2.fc15.x86_64 (Fedora Project) 1320287312
:/usr/lib64/libXi.so.6.1.0 libXi-1.4.5-1.fc16.x86_64 (Fedora Project) 1334119920
:/usr/bin/xscreensaver xscreensaver-base-1:5.15-3.fc16.x86_64 (Fedora Project) 1334273632
:/lib64/libpam.so.0.83.1 pam-1.1.5-5.fc16.x86_64 (Fedora Project) 1334105064

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:SSH_AGENT_PID=2586
:HOSTNAME=its27940.tollgroup.local
:ATS_HOME=/home/aurelica/workspace/dev/ats
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GPG_AGENT_INFO=/home/aurelica/.gnupg/S.gpg-agent:2610:1
:GLADE_PIXMAP_PATH=:
:XDG_MENU_PREFIX=xfce-
:TERM=dumb
:SHELL=/bin/bash
:HISTSIZE=1000
:XDG_SESSION_COOKIE=c7db827ff9b9d7855303f9d20000000b-1336710537.632910-1581430019
:OIDE_JAVA_HOME=/usr/java/x86/jdk1.6.0_32
:QTDIR=/usr/lib64/qt-3.3
:GNOME_KEYRING_CONTROL=/tmp/keyring-J5gfEM
:QTINC=/usr/lib64/qt-3.3/include
:ANT_HOME=/home/aurelica/dev/apache-ant-1.7.1
:IMSETTINGS_MODULE=none
:http_proxy=http://aurelica:Cabelin4@itproxy-farm.toll.com.au:8080
:USER=aurelica
:GLADE_MODULE_PATH=:
:SSH_AUTH_SOCK=/tmp/ssh-uWmQrbOr2448/agent.2448
:JAVA_HOME_1_6_31=/usr/java/jdk1.6.0_31
:USERNAME=aurelica
:XDG_CONFIG_DIRS=/etc/xdg
:MAIL=/var/spool/mail/aurelica
:DESKTOP_SESSION=xfce
:PATH=/usr/lib64/qt-3.3/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/aurelica/.local/bin:/home/aurelica/bin
:QT_IM_MODULE=xim
:PWD=/home/aurelica
:JAVA_HOME=/usr/java/x86/jdk1.5.0_22
:XMODIFIERS=@im=none
:KDE_IS_PRELINKED=1
:LANG=en_US.UTF-8
:GNOME_KEYRING_PID=2442
:JAVA_HOME_1_6_x86=/usr/java/x86/jdk1.6.0_32
:KDEDIRS=/usr
:'OC4J_JVM_ARGS=-XX:MaxPermSize=512m -Xmx1024m -Doc4j.userThreads=true -Xdebug -Xrunjdwp:transport=dt_socket,address=1044,server=y,suspend=n -Dcom.sun.management.jmxremote.port=8686 -Dcom.sun.management.jmxremote.authenticate=false -Dcom.sun.management.jmxremote.ssl=false'
:GDMSESSION=xfce
:SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
:HISTCONTROL=ignoredups
:SHLVL=2
:XDG_SEAT=seat0
:HOME=/home/aurelica
:LOGNAME=aurelica
:QTLIB=/usr/lib64/qt-3.3/lib
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-EZKKC3KtTG,guid=1e917a0fcc55b757ec806cb700000034
:XDG_DATA_DIRS=/usr/local/share:/usr/share
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:DISPLAY=:0
:XDG_RUNTIME_DIR=/run/user/aurelica
:GLADE_CATALOG_PATH=:
:LIBGLADE_MODULE_PATH=:
:ORACLE_HOME=/home/aurelica/dev/oc4j_extended_101350
:XAUTHORITY=/var/run/gdm/auth-for-aurelica-xMgdGK/database
:_=/usr/bin/xscreensaver

smolt_data:
:
:
:General
:=================================
:UUID: 98f22ad0-1387-45b1-b451-8dbb758234fe
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 4999.51
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM)2 Quad  CPU   Q9300  @ 2.50GHz
:CPU Stepping: 7
:CPU Family: 6
:CPU Model Num: 23
:Number of CPUs: 4
:CPU Speed: 2500
:System Memory: 7970
:System Swap: 10015
:Vendor: Hewlett-Packard
:System: HP xw4600 Workstation 
:Form factor: Mini Tower
:Kernel: 3.3.4-3.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(5348:5755:4156:4872) pci, tg3, ETHERNET, NetXtreme BCM5755 Gigabit Ethernet PCI Express
:(32902:10550:4156:4872) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #3
:(32902:10274:4156:4872) pci, ahci, RAID, 82801 SATA RAID Controller
:(32902:10560:4156:4872) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 1
:(32902:10518:4156:4872) pci, None, PCI/ISA, 82801IR (ICH9R) LPC Interface Controller
:(4318:1071:4318:1170) pci, nouveau, VIDEO, G86 [Quadro NVS 290]
:(32902:10568:4156:4872) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 5
:(32902:10558:4156:4872) pci, snd_hda_intel, MULTIMEDIA, 82801I (ICH9 Family) HD Audio Controller
:(32902:10549:4156:4872) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #2
:(32902:9294:4156:4872) pci, None, PCI/PCI, 82801 PCI Bridge
:(32902:10554:4156:4872) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #1
:(32902:10548:4156:4872) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #1
:(32902:10551:4156:4872) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #4
:(32902:10552:4156:4872) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #5
:(32902:10720:4156:4872) pci, x38_edac, HOST/PCI, 82X38/X48 Express DRAM Controller
:(32902:10721:4156:4872) pci, pcieport, PCI/PCI, 82X38/X48 Express Host-Primary PCI Express Bridge
:(32902:10553:4156:4872) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #6
:(32902:10570:4156:4872) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 6
:(32902:10556:4156:4872) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #2
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_its27940-lv_root / ext4 4096 4096 13092026 10256724 10125702 3276800 3021719 3021719
:/dev/md126p3 /boot ext4 1024 1024 508745 409690 384090 128016 127779 127779
:/dev/md126p1 WITHHELD fuseblk 4096 4096 32768575 16213230 16213230 65180600 64874923 64874923
:/dev/md126p5 WITHHELD fuseblk 4096 4096 178652832 160813836 160813836 644041776 643442351 643442351
:/dev/mapper/vg_its27940-lv_home /home ext4 4096 4096 16936403 12958543 12110262 4243456 4079518 4079518
:

xsession_errors:
:xscreensaver-command: activating and locking.
:xscreensaver-command: activating and locking.
:xscreensaver: 21:19:45: authentication via PAM timed out.
:xscreensaver: 10:35:27: couldn't fork: Resource temporarily unavailable
:xscreensaver: 10:35:27: couldn't fork: Resource temporarily unavailable
:xscreensaver: 10:35:27: dumping core (couldn't fork)
:xscreensaver: 10:35:27: see http://www.jwz.org/xscreensaver/bugs.html
:xscreensaver: 10:35:27: current directory is /home/aurelica
:xscreensaver: 10:35:27: running as aurelica/aurelica (1000/1000)
Comment 1 Aurelio Calegari 2012-05-13 18:41:58 EDT
Created attachment 584186 [details]
File: event_log
Comment 2 Aurelio Calegari 2012-05-13 18:42:00 EDT
Created attachment 584187 [details]
File: backtrace
Comment 3 Aurelio Calegari 2012-05-13 18:42:20 EDT
Created attachment 584188 [details]
File: coredump
Comment 4 Aurelio Calegari 2012-05-13 18:42:23 EDT
Created attachment 584189 [details]
File: maps
Comment 5 Mamoru TASAKA 2012-05-13 21:33:24 EDT
Would you know how many processes were running when this crash happened? (or maybe are many processes running even now?) Or would you have some idea about under what circumstance this issue occurred?
Comment 6 Mamoru TASAKA 2012-05-13 21:36:19 EDT
The reason I am asking this is that it seems that calling fork from xscreensaver process failed because of EAGAIN, usually this is because there are too many processes.
Comment 7 Aurelio Calegari 2012-05-13 21:56:07 EDT
Yes, there were too many process, they all crashed:
- I had two eclipse instances running (each in different workspaces)
- OC4J container running
- Evolution was opened
- Thunar (SVN)
- A number of terminals
- A number of Dolphins (file manager)
- Gedit
- Pidgen

What had crashed when I was back:
-Both eclipses
-Oc4J
-Thunar
-Evolution
-Screen saver (unlocked my computer)

But note: It's 8GB quad core box, and it should cope very well with the above. I run the same sort of load in my MacOSX 10.7 and also in WinXP and don't have this problem.
Comment 8 Aurelio Calegari 2012-05-13 22:04:17 EDT
Sorry, I forgot to mention, I also had Chrome and Firefox open, each with a number of tabs. Both crashed too.
Comment 9 Mamoru TASAKA 2012-05-13 23:10:48 EDT
Well, if issues like that you mentioned on comment 7 is reproducible, seeing processes by 
- ps auwwx
- pstree
may show some clues what is the real culprit (or maybe it was just too many applications were running)...

(In reply to comment #7)
> But note: It's 8GB quad core box, and it should cope very well with the above.
Well, the maximum number of processes is usually not related with the capacity of your machine (nowadays), but is determined by the (default) settings of kernel and OS (Fedora). You can see the current value by $ ulimit -u (or $ ulimit -a will show the same information with some explanation).
Comment 10 Aurelio Calegari 2012-05-14 00:30:49 EDT
[aurelica@its27940 home]$ ulimit -u
1024
[aurelica@its27940 home]$ ulimit -a
core file size          (blocks, -c) 0
data seg size           (kbytes, -d) unlimited
scheduling priority             (-e) 0
file size               (blocks, -f) unlimited
pending signals                 (-i) 63597
max locked memory       (kbytes, -l) 64
max memory size         (kbytes, -m) unlimited
open files                      (-n) 1024
pipe size            (512 bytes, -p) 8
POSIX message queues     (bytes, -q) 819200
real-time priority              (-r) 0
stack size              (kbytes, -s) 8192
cpu time               (seconds, -t) unlimited
max user processes              (-u) 1024
virtual memory          (kbytes, -v) unlimited
file locks                      (-x) unlimited

So, that means I had more than 1024 processes running?
Comment 11 Mamoru TASAKA 2012-05-14 01:53:57 EDT
(In reply to comment #10)
> So, that means I had more than 1024 processes running?
Currently I believe so. Maybe one of the applications you were using created many threads or created many zombie processes.
Comment 12 Mamoru TASAKA 2012-05-16 21:01:29 EDT
After some discussion with Red Hat security responsible team and the upstream, I decided to once close this bug as WONTFIX. Thank you for reporting anyway.

Note You need to log in before you can comment on or make changes to this bug.