Bug 821285 - Review Request: rubygem-bunny - A synchronous Ruby AMQP client
Review Request: rubygem-bunny - A synchronous Ruby AMQP client
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Mo Morsi
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 823352
  Show dependency treegraph
 
Reported: 2012-05-13 19:29 EDT by Jonas Courteau
Modified: 2013-01-11 18:15 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-13 00:49:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mmorsi: fedora‑review+
limburgher: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Jonas Courteau 2012-05-13 19:29:39 EDT
Spec URL: https://raw.github.com/jcourteau/rubygems-rpms/master/fc17/rubygem-bunny/rubygem-bunny.spec
SRPM URL: http://rpms.courteau.org/fedora/rubygem-bunny-0.7.9-1.fc17.src.rpm
Description: A synchronous Ruby AMQP client that enables interaction with AMQP-compliant
brokers.

This is the first part of a set of dependencies for rubygem-chef.  I've got about 14 packages to add, all ruby gems, and am looking for a sponsor.  Several of the packages were previously in Fedora (F11 and F12), but were removed due to lack of a maintainer.
Comment 1 Vít Ondruch 2012-05-21 03:52:30 EDT
Please note that rubygem-bunny was already in Fedora [1] but has been retired.

[1] https://admin.fedoraproject.org/pkgdb/acls/name/rubygem-bunny
Comment 2 Julian C. Dunn 2012-11-04 23:41:59 EST
Since there's been no word from Jonas since the summer, I'm starting to take over the work on these packages. I have a new spec and SRPM for rubygem-bunny:

http://jdunn.fedorapeople.org/rubygem-bunny/rubygem-bunny.spec
http://jdunn.fedorapeople.org/rubygem-bunny/rubygem-bunny-0.8.0-1.fc19.src.rpm

I'm prepared to undeprecate the existing Fedora package, as well as maintain this one for EPEL6.
Comment 3 Mo Morsi 2012-11-21 13:14:52 EST
Sorry for the delay, taking this one
Comment 4 Mo Morsi 2012-11-21 13:18:09 EST
rpmlint produces a couple warnings, nothing serious but the macro-in-comment ones should be taken care of (just remove those comments)

rubygem-bunny.src:73: W: macro-in-comment %{buildroot}
rubygem-bunny.src:73: W: macro-in-comment %{gem_instdir}

md5sums:

$ md5sum bunny-0.8.0.gem.*
4fc1d4b2a448538ec88c1ad9ed2c5335  bunny-0.8.0.gem.srpm
4fc1d4b2a448538ec88c1ad9ed2c5335  bunny-0.8.0.gem.upstream

Builds fine in Koji:

http://koji.fedoraproject.org/koji/taskinfo?taskID=4713563

Shame we can't run the tests, but looks like it for the same reason we aren't running them in the rubygem-pg rpm as a running server is required. Would be nice to look into a way to mock this stuff somehow at some point (perhaps we can build a component to take care of both cases if it doesn't exist), but obviously not a blocker for inclusion.

Lastly I just want to ensure excluding the Gemfile from the package won't pose a problems. I did quickly try one of the examples from the rpm and it worked so I assume all is good.

Everything else looks fine and is in accordance w/ the guidelines.

ACK
Comment 5 Julian C. Dunn 2012-11-23 15:03:03 EST
Package Change Request
======================
Package Name: rubygem-bunny
New Branches: fc16 fc17 fc18 el6
Owners: jdunn
InitialCC: 

Unretiring rubygem-bunny.
Comment 6 Gwyn Ciesla 2012-11-23 15:11:58 EST
Git done (by process-git-requests).
Comment 7 Fedora Update System 2012-12-03 21:19:40 EST
rubygem-bunny-0.7.9-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/rubygem-bunny-0.7.9-2.fc16
Comment 8 Fedora Update System 2012-12-03 21:22:51 EST
rubygem-bunny-0.7.9-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/rubygem-bunny-0.7.9-2.fc17
Comment 9 Fedora Update System 2012-12-03 21:23:27 EST
rubygem-bunny-0.7.9-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/rubygem-bunny-0.7.9-2.fc18
Comment 10 Fedora Update System 2012-12-04 16:09:36 EST
Package rubygem-bunny-0.7.9-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rubygem-bunny-0.7.9-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19645/rubygem-bunny-0.7.9-2.fc18
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2012-12-13 00:50:00 EST
rubygem-bunny-0.7.9-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2012-12-13 00:52:21 EST
rubygem-bunny-0.7.9-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2013-01-11 18:15:15 EST
rubygem-bunny-0.7.9-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.