Bug 821295 - systemd times out starting nut-monitor.service
systemd times out starting nut-monitor.service
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: nut (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michal Hlavinka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-13 21:07 EDT by Benjamin Gilbert
Modified: 2012-05-29 06:24 EDT (History)
1 user (show)

See Also:
Fixed In Version: nut-2.6.3-3.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-29 06:24:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Benjamin Gilbert 2012-05-13 21:07:10 EDT
Description of problem:
"systemctl start nut-monitor.service" causes upsmon to start, run for a short time, and then be killed by systemd.

Version-Release number of selected component (if applicable):
2.6.3-2.fc16

How reproducible:
Always

Steps to Reproduce:
1. systemd start nut-monitor.service
2. Wait, and watch /var/log/messages

Actual results:
upsmon stays running.

Expected results:
systemd eventually kills upsmon, saying: "nut-monitor.service operation timed out. Terminating."

Additional info:
upsmon claims to be unable to write to /var/run/nut/upsmon.pid, probably due to the fact that /var/run/nut does not exist.  nut-monitor.service tries to create /var/run/nut using /usr/bin/systemd-tmpfiles, but systemd-tmpfiles lives in /bin, not /usr/bin.
Comment 1 Michal Hlavinka 2012-05-14 07:40:32 EDT
Right, UsrMove happened on F17+ only.
Comment 2 Fedora Update System 2012-05-14 10:40:46 EDT
nut-2.6.3-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/nut-2.6.3-3.fc16
Comment 3 Fedora Update System 2012-05-14 10:40:54 EDT
nut-2.6.3-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/nut-2.6.3-3.fc15
Comment 4 Fedora Update System 2012-05-15 19:25:02 EDT
Package nut-2.6.3-3.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing nut-2.6.3-3.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7899/nut-2.6.3-3.fc16
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-05-29 06:24:46 EDT
nut-2.6.3-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2012-05-29 06:24:57 EDT
nut-2.6.3-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.