Bug 821330 - oz-install crashes: Only the first console can be a serial port
oz-install crashes: Only the first console can be a serial port
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: oz (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pádraig Brady
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-14 02:54 EDT by Matthias Runge
Modified: 2016-01-04 09:45 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-24 19:55:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Runge 2012-05-14 02:54:07 EDT
Description of problem:
following the guide  from here
https://fedoraproject.org/wiki/Getting_started_with_OpenStack_on_Fedora_17#Building_Fedora_16_JEOS_Images_With_Oz

to generate an own image, it stops with the following backtrace:

INFO:oz.Guest.FedoraGuest:Cleaning up guest named fedora16_x86_64
INFO:oz.Guest.FedoraGuest:Cleaning up after install
Traceback (most recent call last):
  File "/bin/oz-install", line 148, in <module>
    libvirt_xml = guest.install(timeout, force_download)
  File "/usr/lib/python2.7/site-packages/oz/Guest.py", line 1427, in install
    return self._do_install(timeout, force, 0)
  File "/usr/lib/python2.7/site-packages/oz/Guest.py", line 1408, in _do_install
    dom = self.libvirt_conn.createXML(xml, 0)
  File "/usr/lib64/python2.7/site-packages/libvirt.py", line 2420, in createXML
    if ret is None:raise libvirtError('virDomainCreateXML() failed', conn=self)
libvirt.libvirtError: unsupported configuration: Only the first console can be a serial port


Version-Release number of selected component (if applicable):
[root@mrungexp mrunge]# rpm -q oz
oz-0.7.0-4.fc17.noarch


How reproducible:
100%

Steps to Reproduce:
1. described at the page linked above: oz-install -d4 -u f16-jeos.tdl
  

This happens on two different machines, both f17, on fresh install, one upgraded.
Comment 2 Matthias Runge 2012-05-14 07:06:51 EDT
That is much better, but sadly crashes at a later point:

DEBUG:oz.Guest.FedoraGuest:Waiting for fedora16_x86_64 to finish installing, 450/1200
DEBUG:oz.Guest.FedoraGuest:Waiting for fedora16_x86_64 to finish installing, 440/1200
INFO:oz.Guest.FedoraGuest:Cleaning up guest named fedora16_x86_64
INFO:oz.Guest.FedoraGuest:Cleaning up after install
Traceback (most recent call last):
  File "/bin/oz-install", line 152, in <module>
    libvirt_xml = guest.install(timeout, force_download)
  File "/usr/lib/python2.7/site-packages/oz/Guest.py", line 1430, in install
    return self._do_install(timeout, force, 0)
  File "/usr/lib/python2.7/site-packages/oz/Guest.py", line 1412, in _do_install
    self._wait_for_install_finish(dom, timeout)
  File "/usr/lib/python2.7/site-packages/oz/Guest.py", line 535, in _wait_for_install_finish
    raise oz.OzException.OzException(exc_str)
oz.OzException.OzException: No disk activity in 300 seconds, failing.  Check screenshot at /home/mrunge/fedora16_x86_64-1336993113.27.png for more detail

That screenshot is blank (only black pixels to see), You want me to append that?
My hardware is reasonable fast, so I guess, there has to be something else.
Comment 3 Matthias Runge 2012-05-14 07:12:00 EDT
I'll take that back! Looks like everything is fine now.
Don't know what happened earlier. Thanks!
Comment 4 Pádraig Brady 2012-05-14 07:16:15 EDT
No need to append the png
Note oz currently needs to run on real hardware
It might be worth retrying with SELinux disabled just in case
Comment 5 Pádraig Brady 2012-05-14 07:18:09 EDT
Comment 4 overlapped with comment 3
OK I'll close this bug when I update oz (today)
Comment 6 Steven Dake 2012-05-14 08:50:32 EDT
Padraig,

I fixed this exact bug in master some time ago, and can verify the patch made it into 0.8.0.

Regards
-steve
Comment 7 Pádraig Brady 2012-05-14 09:02:24 EDT
Thanks Steven. Update coming up...
Comment 8 Fedora Update System 2012-05-14 09:48:47 EDT
oz-0.8.0-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/oz-0.8.0-1.fc16
Comment 9 Fedora Update System 2012-05-14 09:50:37 EDT
oz-0.8.0-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/oz-0.8.0-1.fc17
Comment 10 Matthias Runge 2012-05-14 14:18:02 EDT
That update fixed this bug for me.
Comment 11 Fedora Update System 2012-05-14 22:32:50 EDT
Package oz-0.8.0-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing oz-0.8.0-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7858/oz-0.8.0-1.fc17
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2012-05-24 19:55:38 EDT
oz-0.8.0-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2012-05-26 03:31:13 EDT
oz-0.8.0-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.