Bug 821334 - Memory leak in video streaming
Memory leak in video streaming
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-server (Show other bugs)
6.3
Unspecified Unspecified
urgent Severity high
: rc
: ---
Assigned To: Yonit Halperin
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-14 03:21 EDT by Yonit Halperin
Modified: 2012-06-20 08:17 EDT (History)
7 users (show)

See Also:
Fixed In Version: spice-server-0.10.1-9.el6
Doc Type: Bug Fix
Doc Text:
No documentation needed
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 08:17:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix for the memory leak part1 (2.30 KB, patch)
2012-05-14 03:24 EDT, Yonit Halperin
no flags Details | Diff
Fix for the memory leak part2 (900 bytes, patch)
2012-05-14 03:24 EDT, Yonit Halperin
no flags Details | Diff
backtrace (404.27 KB, text/plain)
2012-05-18 11:23 EDT, David Jaša
no flags Details

  None (edit)
Description Yonit Halperin 2012-05-14 03:21:52 EDT
Description of problem:

When spice streams a video, the memory of qemu process increases due to a memory leak in spice server (in mjpeg_encoder.c).

How reproducible:
Play a movie in the guest. Preferably, an high resolution video.
E.g., play in repeat mode the "Wildlife In HD" movie that comes with Windows7 guests. After several minutes you can see that the qemu memory usage increases.
Comment 2 Yonit Halperin 2012-05-14 03:24:37 EDT
Created attachment 584269 [details]
Fix for the memory leak part1
Comment 3 Yonit Halperin 2012-05-14 03:24:58 EDT
Created attachment 584270 [details]
Fix for the memory leak part2
Comment 7 Yonit Halperin 2012-05-16 04:07:22 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No documentation needed
Comment 9 David Jaša 2012-05-18 11:23:18 EDT
Created attachment 585438 [details]
backtrace
Comment 10 David Jaša 2012-05-18 11:29:51 EDT
I've encountered a qemu segfault during verification of this bug, backtrace is already attached. I'm not sure if it is caused by fixes for this bug though.
Comment 11 David Jaša 2012-05-18 11:32:31 EDT
Re-reading the bugs again, this bug is fixed and segfault should probably be handled in bug #813826.
Comment 14 errata-xmlrpc 2012-06-20 08:17:35 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0765.html

Note You need to log in before you can comment on or make changes to this bug.