Bug 821352 - Corosync doesn't work with point-to-point connection
Summary: Corosync doesn't work with point-to-point connection
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: corosync
Version: 6.4
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Jan Friesse
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-05-14 08:31 UTC by Jan Friesse
Modified: 2013-02-21 07:50 UTC (History)
2 users (show)

Fixed In Version: corosync-1.4.1-8.el6
Doc Type: Bug Fix
Doc Text:
Cause IP is configured as peer-to-peer (netmask /32). Corosync is started with bindnetaddr to configured IP address. Consequence Corosync is unable to create membership. Corosync sockets are bound to PEERs address instead of local one. Fix Use correct information about local ip. Result Corosync starts and run correctly.
Clone Of:
Environment:
Last Closed: 2013-02-21 07:50:19 UTC
Target Upstream Version:


Attachments (Terms of Use)
Proposed patch (1.33 KB, patch)
2012-05-17 12:52 UTC, Jan Friesse
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0497 normal SHIPPED_LIVE corosync bug fix and enhancement update 2013-02-20 21:18:24 UTC

Description Jan Friesse 2012-05-14 08:31:22 UTC
Description of problem:

ip addr add 192.168.2.111 peer 192.168.2.200 dev eth0

in corosync conf:
bindnetaddr: 192.168.2.111

corosync -f

....
Can't bind ...
...
Interface [192.168.2.200] is up
...

^^^ At least linux netaddr -> ip doesn't work

Version-Release number of selected component (if applicable):
Flatiron

How reproducible:
Always

Actual results:
point-to-point doesn't work

Expected results:
point-to-point works

Additional info:

Comment 1 Steven Dake 2012-05-14 13:07:10 UTC
is netmask set properly?

Comment 2 Jan Friesse 2012-05-14 13:37:56 UTC
(In reply to comment #1)
> is netmask set properly?

Steve, problem is point-to-point and I believe you trust me that I'm able to correctly configure network ;). I've already found main problem.

Comment 3 Jan Friesse 2012-05-17 12:52:00 UTC
Created attachment 585210 [details]
Proposed patch

Patch to use IFA_LOCAL instead of IFA_ADDRESS.

Comment 4 Jan Friesse 2012-05-17 12:54:37 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause
IP is configured as peer-to-peer (netmask /32). Corosync is started with bindnetaddr to configured IP address.

Consequence
Corosync is unable to create membership. Corosync sockets are bound to PEERs address instead of local one.

Fix
Use correct information about local ip.

Result
Corosync starts and run correctly.

Comment 10 errata-xmlrpc 2013-02-21 07:50:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0497.html


Note You need to log in before you can comment on or make changes to this bug.