Bug 821365 - boot winxp guest in amd host very slow and the host call trace.
boot winxp guest in amd host very slow and the host call trace.
Status: CLOSED DUPLICATE of bug 817236
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
x86_64 All
unspecified Severity high
: rc
: ---
Assigned To: Marcelo Tosatti
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-14 05:00 EDT by yunpingzheng
Modified: 2014-03-03 19:12 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-14 12:11:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description yunpingzheng 2012-05-14 05:00:04 EDT
Description of problem:
when i boot a winxp guest in amd host will very slow,and the host will call trace.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.copy winXP-32-virtio.qcow2   image from nfs server  10.66.90.128:/vol/S2/kvmauto/windows_img/ to  root.
2. boot the guestboot a winxp guest

  
Actual results:
boot very slow, more then 20 min,and host call trace.

Expected results:
boot normally.

Additional info:

call trace:
------------[ cut here ]------------
WARNING: at arch/x86/kvm/svm.c:729 svm_adjust_tsc_offset+0xac/0xc0 [kvm_amd]() (Tainted: G        W  ---------------   )
Hardware name: OptiPlex 740 Enhanced
Modules linked in: vfat fat nfs lockd fscache nfs_acl auth_rpcgss vhost_net macvtap macvlan tun kvm_amd kvm sunrpc cpufreq_ondemand powernow_k8 freq_table mperf bridge stp llc ipv6 ppdev parport_pc parport microcode dcdbas serio_raw k8temp edac_core edac_mce_amd snd_hda_codec_idt snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm snd_timer snd soundcore snd_page_alloc sg i2c_nforce2 tg3 ext4 mbcache jbd2 sd_mod crc_t10dif sr_mod cdrom pata_acpi ata_generic sata_nv nouveau ttm drm_kms_helper drm i2c_core mxm_wmi video output wmi dm_mirror dm_region_hash dm_log dm_mod [last unloaded: scsi_wait_scan]
Pid: 382, comm: qemu-kvm Tainted: G        W  ---------------    2.6.32-268.el6.x86_64 #1
Call Trace:
 [<ffffffff8106b6b7>] ? warn_slowpath_common+0x87/0xc0
 [<ffffffff8106b70a>] ? warn_slowpath_null+0x1a/0x20
 [<ffffffffa04e921c>] ? svm_adjust_tsc_offset+0xac/0xc0 [kvm_amd]
 [<ffffffffa049182b>] ? kvm_arch_vcpu_load+0xdb/0x140 [kvm]
 [<ffffffffa0487e35>] ? vcpu_load+0x55/0x80 [kvm]
 [<ffffffffa049adf4>] ? kvm_arch_vcpu_ioctl_run+0x24/0x1000 [kvm]
 [<ffffffff8121a3c1>] ? avc_has_perm+0x71/0x90
 [<ffffffffa0484322>] ? kvm_vcpu_ioctl+0x522/0x670 [kvm]
 [<ffffffff8105b3f3>] ? perf_event_task_sched_out+0x33/0x80
 [<ffffffff812784fc>] ? rb_erase+0x1bc/0x310
 [<ffffffff81054ba0>] ? __dequeue_entity+0x30/0x50
 [<ffffffff8118e5a2>] ? vfs_ioctl+0x22/0xa0
 [<ffffffff8118ea6a>] ? do_vfs_ioctl+0x3aa/0x580
 [<ffffffff8118ecc1>] ? sys_ioctl+0x81/0xa0
 [<ffffffff8100b0f2>] ? system_call_fastpath+0x16/0x1b
---[ end trace 41979d2a53ce41eb ]---


host:
kernel:
kernel-2.6.32-268.el6.x86_64
qemu-kvm
qemu-kvm-0.12.1.2-2.290.el6.x86_64

cpu info
processor	: 1
vendor_id	: AuthenticAMD
cpu family	: 15
model		: 107
model name	: AMD Athlon(tm) Dual Core Processor 5400B
stepping	: 2
cpu MHz		: 2800.000
cache size	: 512 KB
physical id	: 0
siblings	: 2
core id		: 1
cpu cores	: 2
apicid		: 1
initial apicid	: 1
fpu		: yes
fpu_exception	: yes
cpuid level	: 1
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow rep_good extd_apicid pni cx16 lahf_lm cmp_legacy svm extapic cr8_legacy 3dnowprefetch lbrv
bogomips	: 5611.39
TLB size	: 1024 4K pages
clflush size	: 64
cache_alignment	: 64
address sizes	: 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc 100mhzsteps

mem info
[root@amd-5400b-4-4 ~]# free -m 
                total       used       free     shared    buffers     cached
Mem:          3766       3617        148          0         16       1097
-/+ buffers/cache:      2504       1261
Swap:        32767       38         32729

guest info:
winxp 

boot comand:
/usr/libexec/qemu-kvm  \
-name 'vm1' \
-chardev socket,id=qmp_monitor1,path=/tmp/monitor-qmpmonitor1,server,nowait \
-mon chardev=qmp_monitor1,mode=control \
-chardev socket,id=serial_1,path=/tmp/serial-1,server,nowait \
-device isa-serial,chardev=serial_1 \
-device ich9-usb-uhci1,id=usb1,multifunction=off,bus=pci.0,addr=0x4 \
-drive file='/root/winXP-32-virtio.qcow2',index=0,if=none,id=drive1,media=disk,cache=none,format=qcow2,aio=threads \
-device virtio-blk-pci,bus=pci.0,addr=0x5,drive=drive1,id=virtio-disk1 \
-device virtio-net-pci,netdev=iddERa13,mac=9a:ac:e9:f0:d7:f3,id=ndev00iddERa13,bus=pci.0,addr=0x3 \
-netdev tap,id=iddERa13,vhost=on,fd=21 \
-m 2048 \
-smp 2,cores=1,threads=1,sockets=2 \
-cpu 'Opteron_G2'  \
-device usb-tablet,id=usb-tablet1,bus=usb1.0 \
-vnc :0 \
-rtc base=localtime,clock=host,driftfix=slew \
-M rhel6.3.0 \
-boot order=cdn,once=c,menu=off   \
-enable-kvm
Comment 4 Marcelo Tosatti 2012-05-14 12:11:54 EDT

*** This bug has been marked as a duplicate of bug 817236 ***

Note You need to log in before you can comment on or make changes to this bug.