Bug 821373 - Xmodmap not applied consitently
Xmodmap not applied consitently
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gtk3 (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-14 05:26 EDT by arturj
Modified: 2012-05-18 19:39 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-18 19:39:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 674716 None None None Never

  None (edit)
Description arturj 2012-05-14 05:26:23 EDT
Description of problem:
I use a ~/Xmodmap to reverse mouse/touchpad scrolling (natural scolling) and after updating Fedora 16 to Fedora 17 RC this does not work anymore in a consistent manner:

Evolution and most other native GTK apps ignore my settings
Gedit and Firefox still obey my settings

Also tried to set scrolling via "xinput --set-button-map ID 1 2 3 5 4" with the same result.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. run in shell xmodmap -e "pointer = 1 2 3 5 4 7 6 8 9 10 11 12"
2. verify that ALL apps have reverse scolling direction
3.
  
Actual results:
not all apps show same results

Expected results:
reverse works system wide (all apps)

Additional info:
Comment 1 Owen Taylor 2012-05-14 09:37:19 EDT
This is because with current GTK+ its using XInput2 to get scroll events directly from the device rather than working via the old method of sending fake button events 4/5 for the scroll events.

See upstream bug https://bugzilla.gnome.org/show_bug.cgi?id=674716 for detailed discussion and an approach that may work for for Synaptics touchpads.
Comment 2 arturj 2012-05-14 15:04:29 EDT
Will XInput2 on the other hand work with all apps in a consistent manner when setup properly or is Xmodmap still needed for "legacy" apps. Thank you.
Comment 3 Matthias Clasen 2012-05-15 16:13:26 EDT
I don't know, you'll have to try.
Comment 4 Matthias Clasen 2012-05-18 19:39:16 EDT
In any case, this is not a gtk bug - gtk does not apply xmodmap directly.

Note You need to log in before you can comment on or make changes to this bug.