Bug 821434 - fedora-easy-karma fails while reading updates-testing repos
fedora-easy-karma fails while reading updates-testing repos
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: python-fedora (Show other bugs)
17
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Luke Macken
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-14 09:20 EDT by G.Wolfe Woodbury
Modified: 2016-09-19 22:43 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-13 12:05:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen scrape of f-e-k run (903 bytes, text/plain)
2012-05-14 09:20 EDT, G.Wolfe Woodbury
no flags Details

  None (edit)
Description G.Wolfe Woodbury 2012-05-14 09:20:59 EDT
Created attachment 584360 [details]
screen scrape of f-e-k run

Description of problem:
 While trying to read updates-testing repo (local and remote) f-e-k throws a pycurl read error. (attached)

Version-Release number of selected component (if applicable):


How reproducible:
 happens reliably in both 32- and 64-bit installations

Steps to Reproduce:
1.enable updates-testing repo
2.install f-e-k
3.run f-e-k
  
Actual results:
  read (of repo?) terminates early in pycurl

Expected results:
  normal program execution

Additional info:
  happens with current f-e-k in both vbox guests and on x86_64 real hardware
Comment 1 Till Maas 2012-05-14 16:55:07 EDT
The error happens in code from python-fedora, therefore I reassign this bug.
Comment 2 Toshio Ernie Kuratomi 2012-05-15 18:27:46 EDT
Unable to replicate the error here.  The error looks like it would be in bodhi if it's server side so lmacken would need to look at it.  However, it could also be some other sort of configuration problem client-side.  Are you using a proxy or connecting directly to admin.fedoraproject.org?
Comment 3 G.Wolfe Woodbury 2012-05-15 20:12:22 EDT
It is a direct connection, but the error occurs whil f-e-k is trying to read the repository information for updates-testing.

It is pointed at a local copy of the TDS 17-branched mirror.  Re-syncing the repository does not change any of the details.

It seems clearly related to recent changes in the f-e-k dependencies.
Comment 4 Toshio Ernie Kuratomi 2012-05-15 21:28:06 EDT
Had some other people test on Fedora 17.  They are unable to reproduce either.

If the traceback attached to this bug is accurately portraying where this is failing, it isn't when we're retrieving the repodata on the client so it shouldn't have to do with having a mirror of the repository.
Comment 5 G.Wolfe Woodbury 2012-05-16 10:18:28 EDT
see also BZ 822152 for an ABRT dump of another traceback.
Comment 6 Toshio Ernie Kuratomi 2012-05-16 11:09:10 EDT
it looks like something is wrong at your site but I'm not sure what it could be.

Could you try:

$ curl https://admin.fedoraproject.org/updates/list

and see if that works or errors out?
Comment 7 G.Wolfe Woodbury 2012-11-13 12:05:05 EST
It seems to have been some strangeness in pycurl but I can't reproduce it anymore

closing: worksforme

Note You need to log in before you can comment on or make changes to this bug.