Bug 821438 - irclog2html 2.10.0 is completely non-functional
irclog2html 2.10.0 is completely non-functional
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: irclog2html (Show other bugs)
15
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Fabian Affolter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-14 09:31 EDT by Kevin Kofler
Modified: 2012-06-16 14:00 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-08 20:01:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Kofler 2012-05-14 09:31:56 EDT
Description of problem:
Any invocation of irclog2html with any parameters crashes with this error:
Traceback (most recent call last):
  File "/usr/bin/irclog2html", line 56, in <module>
    from _version import __version__ as VERSION, __date__ as RELEASE
ImportError: No module named _version

Version-Release number of selected component (if applicable):
irclog2html-2.10.0-1.fc15.noarch

How reproducible:
Always

Steps to Reproduce:
1. Run irclog2html -s xhtml foo.log, or irclog2html, or irclog2html --help, or irclog2html --version, or …

Actual results:
ImportError: No module named _version

Expected results:
It works.

Additional info:
irclog2html-2.9.2-1.fc15.noarch works fine, I had to downgrade to it.
Comment 1 Fedora Update System 2012-05-15 14:22:39 EDT
irclog2html-2.10.0-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/irclog2html-2.10.0-3.fc15
Comment 2 Fedora Update System 2012-05-15 14:22:49 EDT
irclog2html-2.10.0-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/irclog2html-2.10.0-3.fc17
Comment 3 Fedora Update System 2012-05-15 14:22:58 EDT
irclog2html-2.10.0-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/irclog2html-2.10.0-3.fc16
Comment 4 Kevin Kofler 2012-05-15 16:53:48 EDT
Fetched irclog2html-2.10.0-3.fc15 from Koji, still does not work:

Traceback (most recent call last):
  File "/usr/bin/irclog2html", line 9, in <module>
    load_entry_point('irclog2html==2.10.0', 'console_scripts', 'irclog2html')()
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 337, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2279, in load_entry_point
    return ep.load()
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 1989, in load
    entry = __import__(self.module_name, globals(),globals(), ['__name__'])
ImportError: No module named irclog2html.irclog2html
Comment 5 Fedora Update System 2012-05-18 06:25:00 EDT
Package irclog2html-2.10.0-3.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing irclog2html-2.10.0-3.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8016/irclog2html-2.10.0-3.fc15
then log in and leave karma (feedback).
Comment 6 Kevin Kofler 2012-05-22 16:52:53 EDT
Reopening. The version in updates-testing is still not working (with a different traceback), see comment #4.
Comment 7 Kevin Kofler 2012-05-23 13:33:20 EDT
Fabian, do you need help fixing this? I can have a look if you want.
Comment 8 Fabian Affolter 2012-05-23 15:02:53 EDT
For me 2.10.0-3 is working on Fedora 16. Your help would be appreciated for fixing this issue. I can't say if the package is only working on my system because of some luck.
Comment 9 Kevin Kofler 2012-05-23 15:06:12 EDT
OK, I'll try to figure out what's going wrong ASAP.
Comment 10 Kevin Kofler 2012-05-28 10:23:06 EDT
> For me 2.10.0-3 is working on Fedora 16.

You seem to have a non-RPM installation of the required files. The F16 RPM is missing the same files the F15 RPM is also missing.

Compare the file lists for 2.9.2:
http://koji.fedoraproject.org/koji/rpminfo?rpmID=2481570
and 2.10.0:
http://koji.fedoraproject.org/koji/rpminfo?rpmID=3111231
http://koji.fedoraproject.org/koji/rpminfo?rpmID=3111258
The whole irclog2html package under /usr/share/irclog2html went missing, in particular, there's no irclog2html.py, so it's no wonder that the import is failing.

Moreover, the build.log:
http://kojipkgs.fedoraproject.org/packages/irclog2html/2.10.0/3.fc15/data/logs/noarch/build.log
says:
warning: install_lib: 'build/lib' does not exist -- no Python modules to install
Comment 11 Fedora Update System 2012-05-29 11:47:51 EDT
irclog2html-2.10.0-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/irclog2html-2.10.0-4.fc15
Comment 12 Fedora Update System 2012-05-29 11:48:02 EDT
irclog2html-2.10.0-4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/irclog2html-2.10.0-4.fc16
Comment 13 Fedora Update System 2012-05-29 11:48:12 EDT
irclog2html-2.10.0-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/irclog2html-2.10.0-4.fc17
Comment 14 Fedora Update System 2012-05-29 11:48:30 EDT
irclog2html-2.10.0-4.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/irclog2html-2.10.0-4.el6
Comment 15 Fedora Update System 2012-05-29 17:54:21 EDT
Package irclog2html-2.10.0-4.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing irclog2html-2.10.0-4.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8586/irclog2html-2.10.0-4.fc15
then log in and leave karma (feedback).
Comment 16 Fedora Update System 2012-06-08 20:01:56 EDT
irclog2html-2.10.0-4.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2012-06-08 20:04:14 EDT
irclog2html-2.10.0-4.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2012-06-08 20:06:39 EDT
irclog2html-2.10.0-4.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2012-06-16 14:00:02 EDT
irclog2html-2.10.0-4.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.