Bug 821510 - childsplay-alphabet_sounds_pt is no available
childsplay-alphabet_sounds_pt is no available
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: childsplay (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-14 14:01 EDT by Sergio Monteiro Basto
Modified: 2012-06-02 19:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-26 03:28:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sergio Monteiro Basto 2012-05-14 14:01:09 EDT
Description of problem:
rpm -qi childsplay says : 
(...)
childsplay-alphabet_sounds_pt
(...)

yum install childsplay-alphabet_sounds_pt  
No package childsplay-alphabet_sounds_pt available.


Version-Release number of selected component (if applicable):
childsplay-1.6-3.fc16.noarch


  
Actual results:

No package childsplay-alphabet_sounds_pt available. 

Expected results:

package childsplay-alphabet_sounds_pt available. 

Additional info:
I will look for src.rpm and I know the pt translator and can contact him.
Comment 1 Hans de Goede 2012-05-15 05:06:27 EDT
Thanks for the bug report!

I'm preparing a set of updated childsplay packages fixing this now.
Comment 2 Fedora Update System 2012-05-15 05:34:40 EDT
childsplay-1.6-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/childsplay-1.6-5.fc17
Comment 3 Fedora Update System 2012-05-15 05:35:19 EDT
childsplay-1.6-5.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/childsplay-1.6-5.fc16
Comment 4 Fedora Update System 2012-05-15 12:41:27 EDT
Package childsplay-1.6-5.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing childsplay-1.6-5.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7877/childsplay-1.6-5.fc17
then log in and leave karma (feedback).
Comment 5 Sergio Monteiro Basto 2012-05-16 19:06:58 EDT
yum install --enablerepo=updates-testing childsplay-alphabet_sounds_pt

has install pt sounds,  
I will put my daughter testing it on weekend :) 

Thanks,
Comment 6 Sergio Monteiro Basto 2012-05-17 21:17:42 EDT
hi , 
Sorry testing with:

LANGUAGE=pt childsplay --no-exit-question


I don't know if we can fix this or should we report upstream ?

2012-05-18 02:14:18,034 - schoolsplay.SPMainCore.MainCoreGui - ERROR - Error in flashcards start
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/childsplay_sp/SPMainCore.py", line 357, in start_start
    self.activity.start()
  File "/usr/lib/python2.7/site-packages/childsplay_sp/lib/flashcards.py", line 370, in start
    self.SPG.tellcore_info_dialog(_("Your language, %s, is not supported.\n I will now switch to English" % self.loc))
AttributeError: Activity instance has no attribute 'loc'
2012-05-18 02:14:18,035 - schoolsplay.SPMainCore.MainCoreGui - ERROR - : Activity instance has no attribute 'loc'

Thanks,
Comment 7 Sergio Monteiro Basto 2012-05-17 21:18:55 EDT
others activities work well.
Comment 8 Hans de Goede 2012-05-18 02:54:34 EDT
(In reply to comment #6)
> hi , 
> Sorry testing with:
> 
> LANGUAGE=pt childsplay --no-exit-question
> 
> 
> I don't know if we can fix this or should we report upstream ?
> 
> 2012-05-18 02:14:18,034 - schoolsplay.SPMainCore.MainCoreGui - ERROR - Error in
> flashcards start
> Traceback (most recent call last):
>   File "/usr/lib/python2.7/site-packages/childsplay_sp/SPMainCore.py", line
> 357, in start_start
>     self.activity.start()
>   File "/usr/lib/python2.7/site-packages/childsplay_sp/lib/flashcards.py", line
> 370, in start
>     self.SPG.tellcore_info_dialog(_("Your language, %s, is not supported.\n I
> will now switch to English" % self.loc))
> AttributeError: Activity instance has no attribute 'loc'
> 2012-05-18 02:14:18,035 - schoolsplay.SPMainCore.MainCoreGui - ERROR - :
> Activity instance has no attribute 'loc'
> 
> Thanks,

This is more or less expected behavior, the flashcard activity uses a different set of sounds (spoken animal names), which is not yet available in all the supported languages. I assume that childsplay does keep running, but the sounds for the activity are in English? If so this is not a bug.

You can help fix this by getting a decent mic, hook it up to your laptop and then:
1) Start a recording program
2) Have someone (ie yourself) say a needed animal name in Portugeese
3) Stop recording, save under <name-in-english.wav>
4) Goto 1

See /usr/share/childsplay_sp/CPData/FlashcardsData/names/en/ for all needed names, once you've all the recordings you should edit them all in audacity to remove silence at the beginning and end.

Then put them all in a tarbal, put that tarbal somewhere on the web, and send a link to it upstream, please include a statement that you license the sounds under GPL version 3 or later.

If you CC me on the mail to upstream, I'll try to include the sounds in the Fedora packages even before a new upstream release comes along.
Comment 9 Sergio Monteiro Basto 2012-05-18 08:46:07 EDT
Ok , I will see that later, the report is about  Traceback 
instead do the dialog of ...
Comment 10 Hans de Goede 2012-05-18 10:28:05 EDT
(In reply to comment #9)
> Ok , I will see that later, the report is about  Traceback 
> instead do the dialog of ...

Just to make sure I understand you correctly, besides the traceback being printed to the terminal, childsplay also stops rather then continuing with the activity?

(it is "normal" for python programs to sometimes print a traceback and then continue).
Comment 11 Sergio Monteiro Basto 2012-05-18 11:10:17 EDT
(In reply to comment #10)
> (In reply to comment #9)
> > Ok , I will see that later, the report is about  Traceback 
> > instead do the dialog of ...
> 
> Just to make sure I understand you correctly, besides the traceback being
> printed to the terminal, childsplay also stops rather then continuing with the
> activity?

oh yes , doesn't allow enter in activity . 

> (it is "normal" for python programs to sometimes print a traceback and then
> continue).

not in this case
Comment 12 Hans de Goede 2012-05-18 13:04:49 EDT
(In reply to comment #11)
> (In reply to comment #10)
> > (In reply to comment #9)
> > > Ok , I will see that later, the report is about  Traceback 
> > > instead do the dialog of ...
> > 
> > Just to make sure I understand you correctly, besides the traceback being
> > printed to the terminal, childsplay also stops rather then continuing with the
> > activity?
> 
> oh yes , doesn't allow enter in activity . 
> 

Ok, can you please file a new bug for this? This is likely not pt specific, it will happen with
any language where the flashcard sounds are missing...

Thanks,

Hans
Comment 13 Fedora Update System 2012-05-23 10:29:46 EDT
childsplay-1.6-6.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/childsplay-1.6-6.fc16
Comment 14 Fedora Update System 2012-05-26 03:28:16 EDT
childsplay-1.6-5.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2012-06-02 19:54:49 EDT
childsplay-1.6-6.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.