Bug 821530 - All 3.3.x kernels cause PANIC: early exception on HP xw9300 system
All 3.3.x kernels cause PANIC: early exception on HP xw9300 system
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-14 15:50 EDT by hbrown
Modified: 2013-02-13 10:39 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-13 10:39:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hbrown 2012-05-14 15:50:37 EDT
Description of problem:

I have an HP xw9300 system that worked fine with all F16 kernels up to and including 3.2.10-3. I have attempted to update and boot from all 3.3.x kernels that have been released since then. Each attempt to boot results in a boot screen similar to:

#--------------------------
Loading Fedora (3.3.5-2.fc16.x86_64)
Loading initial ramdisk ...



PANIC: early exception 08 rip 246:10 error ffffffff8103dc86 cr2 ffff88007fff9000
#---------------------------

Version-Release number of selected component (if applicable):
This has occurred with all 3.3.x kernel packages.



How reproducible:
Always


Steps to Reproduce:
1. Upgrade to latest 3.3.x kernel
2. Reboot
3. Select 3.3.x kernel in grub
  
Actual results:
kernel panic


Expected results:
System boots normally.

Additional info:

The system is at the most recent bios.
Comment 1 hbrown 2012-05-14 18:03:59 EDT
Attempts to boot from the F17 Beta x86_64 DVD iso result in the system stopping at a grey screen with a blinking white cursor in the upper left when using both the regular boot target and the basic video boot target. If I alter the boot line to remove the 'quiet' option, it stalls after printing

Probing EDD (edd=off to disable)... ok
Comment 2 Aniket 2012-05-17 00:03:40 EDT
I am seeing similar issues with F16 on Dell Studio XPS 13. All 3.3+ kernels I tried fail to boot with kernel panic . I have Atheros 9280 WLan adapter and Nvidia 9400M onboard graphics in my laptop.
Comment 3 gr88gxp 2012-05-17 17:27:06 EDT
Me to xw9300 


Call Trace:
	[ffffffff81d105c8>] __alloc_bootmem_node+0x5c/0x92
	[ffffffff815d4323>] sparce_index_alloc+0x80/0xcb
	[ffffffff81d112f7>] sparce_memory_present_with_active_regiones+0x3c/0x64
	[ffffffff81d04785>] paging_init+0xe/0x22
	[ffffffff81cf5d8c>] setup_arch+0xa14/0xae6
	{ffffffff815ea9c6>] ? printk+0x51/0x53
	[ffffffff81cf0912>] start_kernel+0xd4/0x3c5
	[ffffffff81cf0346>] x86_64_start_reservations+0x131/0x135
	[ffffffff81cf0140>] ? early_idt_handlers+0x140/0x140
	[ffffffff81cf044c>] x86_64_start_kernel+0x102/0x111
       Code: 48 89 c7 45 31 e4 e8 81 60 02 00 48 85 c0 48 89 c2 74 22 49 bc 00 00 00 00 00 88
       ff ff 48 89 d9 48 89 de 49 01 c4 31 c0 4c 89 e7 <f3> aa 48 89 d7 e8 31 67 02 00 5b 4c 89
       e0 41 5c 5d c3 55 48 89
	RIP  [ffffffff81d10232>] __alloc_memory_core_early+0x52/0x64
	 RSP <ffffffff81c01d78>
	CR2: fff88007fff9000
	---[ end trace a7919e7f17c0a725 ]---
	Kernel panic - not syncing: Attempted to kill the idle task!
Comment 4 hbrown 2012-05-22 11:48:33 EDT
Fails again with 3.3.6. However, if I disable "Memory Remapping" in the bios, I can boot, but I lose ~600MB of memory (the system has 4gb of memory).
Comment 5 gr88gxp 2012-06-16 01:44:12 EDT
[    0.000000] Linux version 3.3.8-1.fc16.x86_64 (mockbuild@x86-01.phx2.fedorapr
oject.org) (gcc version 4.6.3 20120306 (Red Hat 4.6.3-2) (GCC) ) #1 SMP Mon Jun 
4 20:49:02 UTC 2012
[    0.000000] Command line: ro root=LABEL=/  direct 5 
 LANG=en_US.UTF-8 rdblacklist=nouveau nouveau.modeset=0 numa=off
[    0.000000] BIOS-provided physical RAM map:
[    0.000000]  BIOS-e820: 0000000000000000 - 000000000009d400 (usable)
[    0.000000]  BIOS-e820: 000000000009d400 - 00000000000a0000 (reserved)
[    0.000000]  BIOS-e820: 00000000000e8000 - 0000000000100000 (reserved)
[    0.000000]  BIOS-e820: 0000000000100000 - 000000007fff9300 (usable)
[    0.000000]  BIOS-e820: 000000007fff9300 - 0000000080000000 (reserved)
[    0.000000]  BIOS-e820: 00000000fec00000 - 0000000100000000 (reserved)
[    0.000000]  BIOS-e820: 0000000100000000 - 0000000180000000 (usable)
[    0.000000] NX (Execute Disable) protection: active
[    0.000000] DMI 2.3 present.
[    0.000000] DMI: Hewlett-Packard HP xw9300 Workstation/09C4h, BIOS 786B9 v2.0
9 11/28/2006


numa=off
Comment 6 Dave Jones 2012-10-23 11:27:10 EDT
# Mass update to all open bugs.

Kernel 3.6.2-1.fc16 has just been pushed to updates.
This update is a significant rebase from the previous version.

Please retest with this kernel, and let us know if your problem has been fixed.

In the event that you have upgraded to a newer release and the bug you reported
is still present, please change the version field to the newest release you have
encountered the issue with.  Before doing so, please ensure you are testing the
latest kernel update in that release and attach any new and relevant information
you may have gathered.

If you are not the original bug reporter and you still experience this bug,
please file a new report, as it is possible that you may be seeing a
different problem. 
(Please don't clone this bug, a fresh bug referencing this bug in the comment is sufficient).
Comment 7 hbrown 2012-10-29 15:55:23 EDT
If I re-enable memory re-mapping in the BIOS, the 3.6.2-1 kernel still causes an early panic exception. Disabling the memory re-mapping in the BIOS is still a workaround.
Comment 8 Fedora End Of Life 2013-01-16 09:33:11 EST
This message is a reminder that Fedora 16 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 16. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '16'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 16's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 16 is end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" and open it against that version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Fedora End Of Life 2013-02-13 10:39:49 EST
Fedora 16 changed to end-of-life (EOL) status on 2013-02-12. Fedora 16 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.