Bug 821591 - Alt+PageUp not working for last fuzzy/untranslated entry of whole document using Firefox
Alt+PageUp not working for last fuzzy/untranslated entry of whole document us...
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Usability (Show other bugs)
1.6-SNAPSHOT
Unspecified Unspecified
unspecified Severity low
: ---
: 1.7
Assigned To: David Mason
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-15 00:42 EDT by Joyce Chang
Modified: 2013-03-03 22:19 EST (History)
4 users (show)

See Also:
Fixed In Version: 1.7-SNAPSHOT (20120716-0026)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-11 01:11:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joyce Chang 2012-05-15 00:42:09 EDT
Description of problem:
On the very last fuzzy/untranslated entry of the whole document, it won't work
for Alt+up if you want to navigate back fuzzy/untranslated entries, while the
editor is closed and focus was lost. In this case, Alt+up would only work when
editor is enabled by clicking it, so users can navigate back fuzzy/untranslated
entries.   


Version-Release number of selected component (if applicable):
1.6.0-alpha-3-SNAPSHOT

How reproducible:
always

Steps to Reproduce:
1.visit a document with at the last page with some fuzzy/untranslated entries.
2.go to the last entry on 2nd last page. 
3.click alt+down continuously until cursor moves to the last fuzzy/untranslated the last page, then click alt+down again
4. click alt+up 
  
Actual results:
no response because lost focus 

Expected results:
go back to previous fuzzy/untranslated entry

Additional info:
chrome doesn't have this issue.
Comment 1 David Mason 2012-07-16 20:50:23 EDT
Fixed incidentally, probably due to changes in https://bugzilla.redhat.com/show_bug.cgi?id=830000
Comment 2 Ding-Yi Chen 2012-07-16 22:07:43 EDT
Example document: Fedora Release Notes (f13, zh-Hans) 

VERIFIED with Zanata version 1.7-SNAPSHOT (20120716-0026)

Note You need to log in before you can comment on or make changes to this bug.