Bug 8216 - Bugs in spec file
Bugs in spec file
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: perl (Show other bugs)
6.1
All Linux
medium Severity low
: ---
: ---
Assigned To: Crutcher Dunnavant
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-05 17:34 EST by andrewem
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-15 09:57:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description andrewem 2000-01-05 17:34:52 EST
The spec file creates a configuration override file "config.over" that has
a few bugs in it:

1) The following will always fail as installprefix is the buildroot

     test -d \$installprefix || mkdir \$installprefix
     test -d \$installprefix/bin || mkdir \$installprefix/bin

   To fix, use "mkdir -p" or "makedirhier" instead of "mkdir".

2) By default, Perl builds with "-O2" as the ccflags.
   Add this line:

     optimize=$RPM_OPT_FLAGS
Comment 1 andrewem 2000-01-05 18:15:59 EST
1) Better explanation:
     installprefix=/var/tmp/perl-root/usr
   since /var/tmp/perl-root does not exist yet
     mkdir $installprefix/usr
   will of course fail.

2) Oops...I forgot the quotes :(
     optimize="$RPM_OPT_FLAGS"
Comment 2 Jeff Johnson 2000-01-15 09:57:59 EST
Fixed in perl-5.00503-8 in Raw Hide.

Note You need to log in before you can comment on or make changes to this bug.