Bug 821642 - Sqlite 3.7.11 causes problems with subversion's svnversion command
Sqlite 3.7.11 causes problems with subversion's svnversion command
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sqlite (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-15 04:29 EDT by Paul Black
Modified: 2012-06-08 20:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-08 20:06:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Black 2012-05-15 04:29:01 EDT
Description of problem:
Sqlite 3.7.11 causes problems with subversion's svnversion command

Version-Release number of selected component (if applicable):
3.7.11


How reproducible:
Every time

Steps to Reproduce:
1. Check out something from SVN
2. Run svnversion in checked-out directory
3.
  
Actual results:
[paulb@fedora17]~/software/hub% svnversion 
svn: E200030: sqlite: callback requested query abort
svn: E200030: sqlite: callback requested query abort
[paulb@fedora17]~/software/hub% 


Expected results:
svnversion should run without error

Additional info:
sqlite 3.7.12 allegedly fixes this problem according to http://grokbase.com/p/subversion/dev/124n8wkn4w/sqlite3-3-7-11-breaks-svnversion-e200030-sqlite-callback-requested-query-abort
Comment 1 fda 2012-05-30 21:57:15 EDT
svnversion is still unusable! SQlite has an even newer version 3.7.12.1 released on 2012-May-22
Comment 2 Panu Matilainen 2012-06-01 03:51:43 EDT
At least for me, reproducing this wasn't at all as straightforward as just checking out something from svn: it required checking out something with svn 1.6, upgrading the checkout to svn 1.7 and then svnversion would barf with that error.

sqlite 3.7.12 introduces big piles of test-suite failures here, dealing with that is more effort than I have time for right now, so a cherry-pick fix to 3.7.11 is what rawhide and f17 are going to get for the time being (now that I was able to verify the fix)
Comment 3 Fedora Update System 2012-06-01 04:10:48 EDT
sqlite-3.7.11-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/sqlite-3.7.11-3.fc17
Comment 4 Paul Black 2012-06-01 05:19:17 EDT
There is definitely a path to failure when checking out with SVN 1.7 (so not upgrading from 1.6). Today, I did a checkout with Eclipse (everything was fine at that point) but later svnversion stopped working; my suspicion is that the failure didn't get triggered until the repository version number moved on.

Updating to 3.7.11-3 then sorted this issue for me.

Cheers

Paul
Comment 5 Fedora Update System 2012-06-01 23:53:43 EDT
Package sqlite-3.7.11-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing sqlite-3.7.11-3.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8757/sqlite-3.7.11-3.fc17
then log in and leave karma (feedback).
Comment 6 fda 2012-06-02 08:59:53 EDT
(In reply to comment #5)
> # su -c 'yum update --enablerepo=updates-testing sqlite-3.7.11-3.fc17'

Works for me again, thank you
Comment 7 Fedora Update System 2012-06-08 20:06:29 EDT
sqlite-3.7.11-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.