Bug 821650 - Quota says "Disk quota exceeded" even before actually quota exceeds
Quota says "Disk quota exceeded" even before actually quota exceeds
Status: CLOSED DUPLICATE of bug 765478
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
pre-release
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Nagaprasad Sathyanarayana
: Triaged
Depends On:
Blocks: 848252
  Show dependency treegraph
 
Reported: 2012-05-15 04:36 EDT by shylesh
Modified: 2016-02-17 19:19 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 848252 (view as bug list)
Environment:
Last Closed: 2015-03-03 04:25:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: DP
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description shylesh 2012-05-15 04:36:33 EDT
Description of problem:

Quota exceeds even with the data less than the quota limit.

Version-Release number of selected component (if applicable):
3.3.0qa41

How reproducible:


Steps to Reproduce:
1. created a distribute volume with 2 bricks
2. set quota of 900MB
3. created a file of size 500MB 
4. Create another file of size 400MB but when the second file size if still 270MB, "Disk quota exceeded " message was thrown and dd fails.
5. Further creation of files on the mountpoint is possible.
  
Actual results:

[root@gqac022 mnt]# dd if=/dev/urandom of=400MB bs=1MB count=400
dd: writing `400MB': Disk quota exceeded
271+0 records in
270+0 records out
270520320 bytes (271 MB) copied, 31.941 s, 8.5 MB/s
[root@gqac022 mnt]# echo "akdsjfkasjfkasjdfksajfkasjf" >> 400MB 

Expected results:


Additional info:
Comment 1 shylesh 2012-05-15 04:37:04 EDT
Backend FS XFS with 512 block size.
Comment 2 Vijay Bellur 2012-05-16 14:24:53 EDT
Do we need a documentation update for this?
Comment 3 Saurabh 2012-05-31 04:29:43 EDT
the workaround in the bug https://bugzilla.redhat.com/show_bug.cgi?id=765478, needs to be documented
Comment 4 Amar Tumballi 2012-07-11 07:15:28 EDT
XFS pre-alloc issue. Doc needed.
Comment 5 Federico Leva 2012-11-10 09:50:29 EST
To be marked as duplicate of bug 765478?
Comment 7 Vijaikumar Mallikarjuna 2015-03-03 04:25:39 EST

*** This bug has been marked as a duplicate of bug 765478 ***

Note You need to log in before you can comment on or make changes to this bug.