Bug 8217 - RPM not buildable as non-root
RPM not buildable as non-root
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: pam (Show other bugs)
1.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-05 17:35 EST by Enrico Scholz
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-05 15:18:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2000-01-05 17:35:38 EST
The RPM is not buildable as an ordinary user because /sbin/ldconfig will be
executed in the %install stage (which has no effect at building RPMs).

A workaround is to append "LDCONFIG=:" to the install command:

%install
...
make install FAKEROOT=$RPM_BUILD_ROOT LDCONFIG=:
...
Comment 1 Bill Nottingham 2000-02-05 15:18:59 EST
Should be fixed in the next pam release.

Note You need to log in before you can comment on or make changes to this bug.