Bug 821702 - Turning on CONFIG_NILFS2_FS
Turning on CONFIG_NILFS2_FS
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-15 07:22 EDT by Masatake YAMATO
Modified: 2012-05-16 00:16 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 13:22:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Masatake YAMATO 2012-05-15 07:22:03 EDT
Description of problem:

kernel package is built with "CONFIG_NILFS2_FS is not set".
It should be provided as "m", a kernel module because 
Fedora provides nilfs-utils package.
It is inconsistent.
Comment 1 Josh Boyer 2012-05-15 08:31:15 EDT
Fedora also provides media players that can't play 90% of the media that people release.  There's no consistency requirement when building packages in Fedora, oddly enough.

Anyway, we can turn this back on in rawhide and move it to the modules-extra subpackage but usage of Nilfs2 in Fedora is likely very low.
Comment 2 Josh Boyer 2012-05-15 13:22:16 EDT
Enabled in rawhide.  Will be in tomorrow's build.
Comment 3 Masatake YAMATO 2012-05-16 00:16:16 EDT
Thanks. I'd like to try nilfs2.

Note You need to log in before you can comment on or make changes to this bug.