Bug 821709 - Guest will die if try to mount a disconnected floppy image.
Guest will die if try to mount a disconnected floppy image.
Status: CLOSED DUPLICATE of bug 729244
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Markus Armbruster
Virtualization Bugs
:
Depends On: 729244
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-15 07:50 EDT by Geyang Kong
Modified: 2013-08-04 23:43 EDT (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-25 11:50:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
libvirtd log file (1.08 MB, application/zip)
2012-05-15 07:50 EDT, Geyang Kong
no flags Details
guest output (5.45 KB, text/plain)
2012-07-17 22:40 EDT, Geyang Kong
no flags Details

  None (edit)
Description Geyang Kong 2012-05-15 07:50:40 EDT
Created attachment 584646 [details]
libvirtd log file

Description of problem:
  Guest will die if try to mount a disconnected floppy driver.

Version-Release number of selected component (if applicable):
virt-manager-0.9.0-14.el6.x86_64
libvirt-0.9.10-18.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Make sure there is a running guest.
2. Add a floppy device and connect to an img file.
3. Run #modprobe floppy in guest.
4. Run #mount /dev/floppy /mnt in guest.
5. Make sure floppy image has been mounted to /mnt
6. Run #umount /mnt in guest.
7. Create a floppy eject XML.
   #cat eject.xml
   <disk type='block' device='floppy'>
     <target dev='fda' bus='fdc'/>
   </disk>
8. Run #virsh update-device $guest eject.xml in host
9. Run #mount /dev/floppy /mnt in guest.

Actual results:
1. After step 9. Guest will die.

Expected results:
1. Guest should keep living.

Additional info:
Comment 2 Dave Allan 2012-05-15 08:28:49 EDT
This looks to me like qemu crashing, so I've changed the component to qemu-kvm.  If that's not the case, please reassign back to libvirt.
Comment 3 Dor Laor 2012-05-16 05:28:33 EDT
(In reply to comment #2)
> This looks to me like qemu crashing, so I've changed the component to qemu-kvm.
>  If that's not the case, please reassign back to libvirt.

Did the kernel crashed (maybe a kernel issue) or was it qemu?
Comment 4 Geyang Kong 2012-05-16 06:35:47 EDT
Looks like kernel crash. I can get a line from guest: "Kernel panic - not syncing: Fatal exception."
Comment 6 Markus Armbruster 2012-07-17 07:15:10 EDT
For a guest kernel crash, please provide guest kernel version information.  Output of "uname -a" in guest should do.  Also provide guest's dmesg.  Recommend to capture it on a serial console.
Comment 7 Geyang Kong 2012-07-17 22:40:00 EDT
Created attachment 598775 [details]
guest output

Serial output file attached here. Guest kernel info is 2.6.32-220.el6.x86_64
Comment 8 Pavel Hrdina 2012-07-25 06:59:46 EDT
This bug will be fixed by patches for bug 729244. You can try the whole patch-file attached for that bug.
Comment 9 Markus Armbruster 2012-07-25 11:33:02 EDT
This bug report is really two bugs: 

1. A bug in qemu-kvm floppy device model.  Probably a duplicate of bug 729244 mentioned in comment#8.

2. A bug in the guest kernel, which really shouldn't crash just because the floppy controller acts up.  Probably a duplicate of bug 815472.
Comment 10 Ademar Reis 2012-07-25 11:50:57 EDT
(In reply to comment #8)
> This bug will be fixed by patches for bug 729244. You can try the whole
> patch-file attached for that bug.

(In reply to comment #9)
> This bug report is really two bugs: 
> 
> 1. A bug in qemu-kvm floppy device model.  Probably a duplicate of bug
> 729244 mentioned in comment#8.
> 
> 2. A bug in the guest kernel, which really shouldn't crash just because the
> floppy controller acts up.  Probably a duplicate of bug 815472.

Closing as duplicate of Bug 729244. This scenario should be included in the testcase of Bug 729244.

*** This bug has been marked as a duplicate of bug 729244 ***

Note You need to log in before you can comment on or make changes to this bug.