Bug 821760 - incomprehensible rhn_register UI
incomprehensible rhn_register UI
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rhn-client-tools (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Milan Zázrivec
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-15 09:52 EDT by Karel Volný
Modified: 2012-09-18 04:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-14 07:06:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of the problem (59.62 KB, image/png)
2012-05-15 09:52 EDT, Karel Volný
no flags Details

  None (edit)
Description Karel Volný 2012-05-15 09:52:56 EDT
Created attachment 584672 [details]
screenshot of the problem

Description of problem:
Trying to register my system to RHN, I got some strange errors about needing SSL certificate. In the end, I have found that I've just entered wrong address, following the schema outlined by the dialogue box ...

Version-Release number of selected component (if applicable):
rhn-setup-1.0.0-87.el6.noarch


Please see the attached screenshot.

It says "You may connect your system to Red Hat Network (https://rhn.redhat.com/) or ..." - note the "https://rhn.redhat.com/" form of the URL

It also says "Example: https://satellite.example.com"

Yet when I've used the URL in form "https://rhn.on.my.server" it hasn't worked and I got a message about needing to provide correct SSL certificate.

After providing the URL in the same form as the value of serverURL in /etc/sysconfig/rhn/up2date , i.e. "https://xmlrpc.rhn.on.my.server/XMLRPC", it just magically worked.

This is pretty confusing.

Also the error message doesn't help - at first, I've tried to remove "s" from https, trying unsecured connection ... yet I still got a message about wrong SSL certificate! - How is that possible to have wrong certificate when SSL should not be involved at all?

It'd be more helpful to report something like that the XMLRPC interface could not have been reached (not found) instead of asking for SSL certificate when none is needed.
Comment 4 Milan Zázrivec 2012-09-14 07:06:07 EDT
Terribly sorry, but I'm not able to reproduce any of the issues mentioned
in the opening comment.

When I enter

    https://xmlrpc.rhn.errata.stage.redhat.com

into the dialog box, rhn_register nicely appends '/XMLRPC' to it.

When I enter

    https://xmlrpc.rhn.errata.stage.redhat.com/XMLRPC

into the dialog box, rhn_register proceeds nicely without appending anything.

When I use SSL and do not have the valid CA certificate in place, rhn_register
asks me for correct certificate.

When I use http://... schema, rhn_register does not ask for any certificate
at all.

This is all with rhn-client-tools-1.0.0-87.el6.

I'm closing this with worksforme, you're welcome to re-open with an explanation,
should you disagree.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.