Bug 821780 - netcf: Gnulib bundled but no bundled(gnulib) provides
netcf: Gnulib bundled but no bundled(gnulib) provides
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: netcf (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Laine Stump
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-15 09:56 EDT by Mikolaj Izdebski
Modified: 2012-09-30 21:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-30 21:11:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikolaj Izdebski 2012-05-15 09:56:32 EDT
A bundled copy of Gnulib - The GNU Portability Library [1] was found in
netcf. No Bundled Libraries section [2] of Packaging guidelines
gives more information on bundled libraries and how they should be handled.

Affected netcf version: netcf-0.1.9-2.fc17

As a kind of copylib, Gnulib has been granted an exception. However, to comply
with Packaging guidelines, packages bundling Gnulib must note that the library
has been granted an exception in the spec file comment with a link to the FPC
ticket where the exception was granted and add a virtual provide to the spec
file to note that Gnulib is bundled. Refer to [2] for more details.

No comment about bundling Gnulib and no virtual provide were found in the
netcf.spec file. To comply with the packaging guideliness please
add an appropriate comment to the spec file as well as a virtual provide.

Source tarball where bundled Gnulib was found:
    netcf-0.1.9.tar.gz

At least the following files look like Gnulib files:
    ./netcf-0.1.9/gnulib/m4/00gnulib.m4
    ./netcf-0.1.9/gnulib/tests/Makefile.in
    ./netcf-0.1.9/gnulib/tests/Makefile.am
    ./netcf-0.1.9/gnulib/m4/gnulib-comp.m4
    ./netcf-0.1.9/gnulib/lib/Makefile.in
    ./netcf-0.1.9/gnulib/lib/Makefile.am

There are most likely more Gnulib files bundled in the SRPM. I didn't bother
to list them all as it shouldn't be necessary.


[1] http://www.gnu.org/software/gnulib/
[2] http://fedoraproject.org/wiki/Packaging:No_Bundled_Libraries
Comment 1 David Lutterkort 2012-05-22 11:13:33 EDT
Yes, gnulib is bundled.
Comment 2 Laine Stump 2012-05-22 13:30:29 EDT
I've already pushed a patch for the specfile upstream. It will be included the next time there is a release + Fedora build:

commit eaf4c561a4f25b90332f2f514d51d54500077642
Author: Laine Stump <laine@laine.org>
Date:   Tue May 15 11:23:57 2012 -0400

    Add bundled(gnulib) to RPM specfile
    
    According to Fedora guidelines, because we bundle gnulib we
    need to add a virtual Provides: bundled(gnulib).
    
    https://fedoraproject.org/wiki/Packaging:No_Bundled_Libraries#Requirement_if_you_bundle
Comment 3 Cole Robinson 2012-09-30 21:11:13 EDT
In rawhide now.

Note You need to log in before you can comment on or make changes to this bug.