Bug 821791 - wdiff: Gnulib bundled but no bundled(gnulib) provides
wdiff: Gnulib bundled but no bundled(gnulib) provides
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: wdiff (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Praveen Kumar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-15 09:58 EDT by Mikolaj Izdebski
Modified: 2012-12-20 10:29 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 10:29:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikolaj Izdebski 2012-05-15 09:58:48 EDT
A bundled copy of Gnulib - The GNU Portability Library [1] was found in
wdiff. No Bundled Libraries section [2] of Packaging guidelines
gives more information on bundled libraries and how they should be handled.

Affected wdiff version: wdiff-1.1.0-2.fc17

As a kind of copylib, Gnulib has been granted an exception. However, to comply
with Packaging guidelines, packages bundling Gnulib must note that the library
has been granted an exception in the spec file comment with a link to the FPC
ticket where the exception was granted and add a virtual provide to the spec
file to note that Gnulib is bundled. Refer to [2] for more details.

No comment about bundling Gnulib and no virtual provide were found in the
wdiff.spec file. To comply with the packaging guideliness please
add an appropriate comment to the spec file as well as a virtual provide.

Source tarball where bundled Gnulib was found:
    wdiff-1.1.0.tar.gz

At least the following files look like Gnulib files:
    ./wdiff-1.1.0/m4/00gnulib.m4
    ./wdiff-1.1.0/m4/gnulib-comp.m4
    ./wdiff-1.1.0/lib/po/Makevars
    ./wdiff-1.1.0/lib/po/POTFILES.in
    ./wdiff-1.1.0/lib/Makefile.in
    ./wdiff-1.1.0/lib/Makefile.am

There are most likely more Gnulib files bundled in the SRPM. I didn't bother
to list them all as it shouldn't be necessary.


[1] http://www.gnu.org/software/gnulib/
[2] http://fedoraproject.org/wiki/Packaging:No_Bundled_Libraries
Comment 1 Praveen Kumar 2012-05-29 23:07:41 EDT
Hi Mikolaj,

Recently wdiff newer version came, but have some issue due to get function, I informed to upstream. Will update spec soon as per your report and updated source.
Comment 2 Fedora Update System 2012-05-31 09:06:01 EDT
wdiff-1.1.2-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/wdiff-1.1.2-1.fc17
Comment 3 Fedora Update System 2012-05-31 09:20:35 EDT
wdiff-1.1.2-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/wdiff-1.1.2-1.fc16
Comment 4 Fedora Update System 2012-06-01 12:51:06 EDT
Package wdiff-1.1.2-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing wdiff-1.1.2-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8672/wdiff-1.1.2-1.fc17
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-12-20 10:29:20 EST
wdiff-1.1.2-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.