Bug 821815 - SELinux is preventing /usr/bin/ruby from 'read' accesses on the directory /lib/systemd/system/graphical.target.wants.
SELinux is preventing /usr/bin/ruby from 'read' accesses on the directory /li...
Status: CLOSED DUPLICATE of bug 821810
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:c58e96af2c0264c050b4bda9761...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-15 10:40 EDT by al morris
Modified: 2012-05-15 15:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 15:54:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description al morris 2012-05-15 10:40:21 EDT
libreport version: 2.0.8
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.5-2.fc16.x86_64
reason:         SELinux is preventing /usr/bin/ruby from 'read' accesses on the directory /lib/systemd/system/graphical.target.wants.
time:           Tue 15 May 2012 09:40:11 AM CDT

description:
:SELinux is preventing /usr/bin/ruby from 'read' accesses on the directory /lib/systemd/system/graphical.target.wants.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that ruby should be allowed read access on the graphical.target.wants directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep deltacloudd /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:deltacloudd_t:s0
:Target Context                system_u:object_r:systemd_unit_file_t:s0
:Target Objects                /lib/systemd/system/graphical.target.wants [ dir ]
:Source                        deltacloudd
:Source Path                   /usr/bin/ruby
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           ruby-1.8.7.358-1.fc16.x86_64
:Target RPM Packages           initscripts-9.34.2-1.fc16.x86_64 systemd-
:                              units-37-19.fc16.x86_64
:Policy RPM                    selinux-policy-3.10.0-84.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.5-2.fc16.x86_64 #1 SMP Tue May 8
:                              11:24:50 UTC 2012 x86_64 x86_64
:Alert Count                   3
:First Seen                    Tue 15 May 2012 04:33:25 PM CDT
:Last Seen                     Tue 15 May 2012 04:33:26 PM CDT
:Local ID                      86805f69-521c-49ec-b758-711b948a9adf
:
:Raw Audit Messages
:type=AVC msg=audit(1337117606.120:78): avc:  denied  { read } for  pid=1159 comm="deltacloudd" name="graphical.target.wants" dev="sda3" ino=393994 scontext=system_u:system_r:deltacloudd_t:s0 tcontext=system_u:object_r:systemd_unit_file_t:s0 tclass=dir
:
:
:type=AVC msg=audit(1337117606.120:78): avc:  denied  { open } for  pid=1159 comm="deltacloudd" name="graphical.target.wants" dev="sda3" ino=393994 scontext=system_u:system_r:deltacloudd_t:s0 tcontext=system_u:object_r:systemd_unit_file_t:s0 tclass=dir
:
:
:type=SYSCALL msg=audit(1337117606.120:78): arch=x86_64 syscall=openat success=yes exit=ENXIO a0=ffffffffffffff9c a1=1dde840 a2=90800 a3=0 items=0 ppid=1108 pid=1159 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=deltacloudd exe=/usr/bin/ruby subj=system_u:system_r:deltacloudd_t:s0 key=(null)
:
:Hash: deltacloudd,deltacloudd_t,systemd_unit_file_t,dir,read
:
:audit2allow
:
:#============= deltacloudd_t ==============
:allow deltacloudd_t systemd_unit_file_t:dir { read open };
:
:audit2allow -R
:
:#============= deltacloudd_t ==============
:allow deltacloudd_t systemd_unit_file_t:dir { read open };
:
Comment 1 Miroslav Grepl 2012-05-15 15:54:45 EDT

*** This bug has been marked as a duplicate of bug 821810 ***

Note You need to log in before you can comment on or make changes to this bug.