Bug 821820 - ntpd can't be fully disabled because it does systemd wrong
ntpd can't be fully disabled because it does systemd wrong
Status: CLOSED DUPLICATE of bug 821813
Product: Fedora
Classification: Fedora
Component: ntp (Show other bugs)
17
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
: 832787 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-15 10:42 EDT by Jonathan Kamens
Modified: 2012-10-23 11:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-23 11:39:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2012-05-15 10:42:39 EDT
This link is included in the ntp RPM:

lrwxrwxrwx 1 root root 15 Apr 29 22:10 /lib/systemd/system/systemd-timedated-ntp.target.wants/ntpd.service -> ../ntpd.service

It shouldn't be. Rather, there should be the line in /lib/systemd/system/ntpd.service in the [Install] section:

WantedBy=systemd-timedated-ntp.target

This makes it impossible to fully disable ntpd.

See also bug 821813 for a similar problem in chrony.
Comment 1 Michal Schmidt 2012-05-15 11:39:48 EDT
Let's see if the discussion in bug 821813 results in any alternative solutions.
Comment 2 Miroslav Lichvar 2012-08-07 07:31:10 EDT
*** Bug 832787 has been marked as a duplicate of this bug. ***
Comment 3 Miroslav Lichvar 2012-10-23 11:39:23 EDT
This seems to be addressed in systemd.

*** This bug has been marked as a duplicate of bug 821813 ***

Note You need to log in before you can comment on or make changes to this bug.