Bug 821821 - SELinux is preventing /usr/bin/ruby from 'getattr' accesses on the file /lib/systemd/system/ntpd.service.
SELinux is preventing /usr/bin/ruby from 'getattr' accesses on the file /lib/...
Status: CLOSED DUPLICATE of bug 821810
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:b9e56c09a2dfe80a6a208770ec9...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-15 10:43 EDT by al morris
Modified: 2012-05-15 15:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 15:57:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description al morris 2012-05-15 10:43:20 EDT
libreport version: 2.0.8
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.5-2.fc16.x86_64
reason:         SELinux is preventing /usr/bin/ruby from 'getattr' accesses on the file /lib/systemd/system/ntpd.service.
time:           Tue 15 May 2012 09:43:07 AM CDT

description:
:SELinux is preventing /usr/bin/ruby from 'getattr' accesses on the file /lib/systemd/system/ntpd.service.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that ruby should be allowed getattr access on the ntpd.service file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep deltacloudd /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:deltacloudd_t:s0
:Target Context                system_u:object_r:ntpd_unit_file_t:s0
:Target Objects                /lib/systemd/system/ntpd.service [ file ]
:Source                        deltacloudd
:Source Path                   /usr/bin/ruby
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           ruby-1.8.7.358-1.fc16.x86_64
:Target RPM Packages           ntp-4.2.6p4-1.fc16.x86_64
:Policy RPM                    selinux-policy-3.10.0-84.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.5-2.fc16.x86_64 #1 SMP Tue May 8
:                              11:24:50 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Tue 15 May 2012 04:33:25 PM CDT
:Last Seen                     Tue 15 May 2012 04:33:25 PM CDT
:Local ID                      d0d71ad0-2bb8-477d-80c9-6ac6f5dd6b9e
:
:Raw Audit Messages
:type=AVC msg=audit(1337117605.953:53): avc:  denied  { getattr } for  pid=1159 comm="deltacloudd" path="/lib/systemd/system/ntpd.service" dev="sda3" ino=412336 scontext=system_u:system_r:deltacloudd_t:s0 tcontext=system_u:object_r:ntpd_unit_file_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1337117605.953:53): arch=x86_64 syscall=lstat success=yes exit=0 a0=1d80de0 a1=7fff77f4e3d0 a2=7fff77f4e3d0 a3=1 items=0 ppid=1108 pid=1159 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=deltacloudd exe=/usr/bin/ruby subj=system_u:system_r:deltacloudd_t:s0 key=(null)
:
:Hash: deltacloudd,deltacloudd_t,ntpd_unit_file_t,file,getattr
:
:audit2allow
:
:#============= deltacloudd_t ==============
:allow deltacloudd_t ntpd_unit_file_t:file getattr;
:
:audit2allow -R
:
:#============= deltacloudd_t ==============
:allow deltacloudd_t ntpd_unit_file_t:file getattr;
:
Comment 1 Miroslav Grepl 2012-05-15 15:57:17 EDT

*** This bug has been marked as a duplicate of bug 821810 ***

Note You need to log in before you can comment on or make changes to this bug.