Bug 821842 - SELinux is preventing /usr/bin/ruby from 'getattr' accesses on the file /lib/udev/udev-configure-printer.
SELinux is preventing /usr/bin/ruby from 'getattr' accesses on the file /lib/...
Status: CLOSED DUPLICATE of bug 821810
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:124670514fcb1cdf6984a4bf42b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-15 10:50 EDT by al morris
Modified: 2012-05-15 16:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 16:03:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description al morris 2012-05-15 10:50:10 EDT
libreport version: 2.0.8
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.5-2.fc16.x86_64
reason:         SELinux is preventing /usr/bin/ruby from 'getattr' accesses on the file /lib/udev/udev-configure-printer.
time:           Tue 15 May 2012 09:50:01 AM CDT

description:
:SELinux is preventing /usr/bin/ruby from 'getattr' accesses on the file /lib/udev/udev-configure-printer.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that ruby should be allowed getattr access on the udev-configure-printer file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep deltacloudd /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:deltacloudd_t:s0
:Target Context                system_u:object_r:cupsd_config_exec_t:s0
:Target Objects                /lib/udev/udev-configure-printer [ file ]
:Source                        deltacloudd
:Source Path                   /usr/bin/ruby
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           ruby-1.8.7.358-1.fc16.x86_64
:Target RPM Packages           system-config-printer-udev-1.3.8-4.fc16.x86_64
:Policy RPM                    selinux-policy-3.10.0-84.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.5-2.fc16.x86_64 #1 SMP Tue May 8
:                              11:24:50 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Tue 15 May 2012 04:33:27 PM CDT
:Last Seen                     Tue 15 May 2012 04:33:27 PM CDT
:Local ID                      b420916e-90e7-4557-b22c-83c2d8d88b4e
:
:Raw Audit Messages
:type=AVC msg=audit(1337117607.183:103): avc:  denied  { getattr } for  pid=1159 comm="deltacloudd" path="/lib/udev/udev-configure-printer" dev="sda3" ino=411844 scontext=system_u:system_r:deltacloudd_t:s0 tcontext=system_u:object_r:cupsd_config_exec_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1337117607.183:103): arch=x86_64 syscall=lstat success=yes exit=0 a0=1d80de0 a1=7fff77f4e520 a2=7fff77f4e520 a3=1 items=0 ppid=1108 pid=1159 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=deltacloudd exe=/usr/bin/ruby subj=system_u:system_r:deltacloudd_t:s0 key=(null)
:
:Hash: deltacloudd,deltacloudd_t,cupsd_config_exec_t,file,getattr
:
:audit2allow
:
:#============= deltacloudd_t ==============
:allow deltacloudd_t cupsd_config_exec_t:file getattr;
:
:audit2allow -R
:
:#============= deltacloudd_t ==============
:allow deltacloudd_t cupsd_config_exec_t:file getattr;
:
Comment 1 Miroslav Grepl 2012-05-15 16:03:01 EDT

*** This bug has been marked as a duplicate of bug 821810 ***

Note You need to log in before you can comment on or make changes to this bug.