Bug 821848 - modification of olcSyncrepl attribute takes server out of MirrorMode
modification of olcSyncrepl attribute takes server out of MirrorMode
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: openldap (Show other bugs)
6.2
All All
unspecified Severity unspecified
: rc
: ---
Assigned To: Jan Vcelak
David Spurek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-15 11:04 EDT by Patrick Hemmer
Modified: 2015-03-02 00:26 EST (History)
4 users (show)

See Also:
Fixed In Version: openldap-2.4.23-29.el6
Doc Type: Bug Fix
Doc Text:
Cause: Replication in mirror mode is configured for OpenLDAP server (slapd) configuration database (cn=config). Replication configuration (olcSyncrepl) is changed. Consequence: The cn=config database is silently removed from mirror mode and it cannot be longer modified without restarting the slapd daemon. Fix: Upstream patch applied to fix correctly handle the changes of replication configuration. Result: Change of replication configuration preservers the state of mirror mode correctly, cn=config database can be modified with no need to restart the slapd daemon.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 04:45:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick Hemmer 2012-05-15 11:04:32 EDT
When slapd is running with cn=config, and "olcMirrorMode: TRUE" is set, whenever you modify an "olcSyncrepl" attribute, the server is silently taken out of MirrorMode, and you are no longer able to edit the cn=config database until slapd is restarted.

This is observed with openldap-servers-2.4.23-20.el6.x86_64

Steps to Reproduce:
1. Create a server with "olcMirrorMode: TRUE" and perform a modification on an "olcSyncrepl" attribute.
2. Then try to modify anything in the cn=config database.

 
Actual results:
"shadow context; no update referral"


Expected results:
No error


Additional info:
This has been reported and fixed upstream
http://www.openldap.org/its/index.cgi/Software%20Bugs?id=7077
http://www.openldap.org/devel/gitweb.cgi?p=openldap.git;a=commitdiff;h=b8f4e78414d59e76d626b3f0ae1c113ba1b1fc2c
Comment 2 RHEL Product and Program Management 2012-05-19 00:04:18 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 Jan Vcelak 2012-07-31 08:33:18 EDT
Confirming. Upstream patch can be applied.
Comment 5 Jan Vcelak 2012-09-25 12:10:25 EDT
Resolved in: openldap-2.4.23-29.el6
Comment 9 errata-xmlrpc 2013-02-21 04:45:53 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0364.html

Note You need to log in before you can comment on or make changes to this bug.