Bug 821854 - [plugin-container] hundreds of "Access to resource [Resource[id=xxxxx]...] will fail due to missing classloader!" errors written to agent log during resource upgrade at PC startup
[plugin-container] hundreds of "Access to resource [Resource[id=xxxxx]...] wi...
Status: CLOSED NOTABUG
Product: RHQ Project
Classification: Other
Component: Plugin Container (Show other bugs)
4.4
Unspecified Unspecified
urgent Severity urgent (vote)
: ---
: JON 3.1.0
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks: as7-plugin
  Show dependency treegraph
 
Reported: 2012-05-15 11:15 EDT by Ian Springer
Modified: 2013-08-05 20:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
RHQ master, 2 EAP6 ER6 domain controllers running
Last Closed: 2012-05-15 12:18:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ian Springer 2012-05-15 11:15:45 EDT
I see hundreds of the below errors in my Agent log during Agent startup (519 to be exact). All of them have the same stack trace. Note, they occur during the sync that is initiated by InventoryManager.activateAndUpgradeResources(). *** All 519 of the errors are for JBossAS7 Resources ***  This must be a clue as to what the underlying cause is. Perhaps it's something specific to Resources with runs-inside types, of which the as7 plugin has many.

---

2012-05-15 11:02:21,209 ERROR [main] (rhq.core.pc.inventory.InventoryManager)- Access to resource [Resource[id=12102, uuid=03f42cda-00c5-40ea-9d58-2414a9932468, type={JBossAS7}Connection Factory, key=profile=full,subsystem=messaging,hornetq-server=default,connection-factory=RemoteConnectionFactory, name=RemoteConnectionFactory, parent=default]] will fail due to missing classloader!
org.rhq.core.clientapi.agent.PluginContainerException: Failed to obtain classloader for resource: Resource[id=12102, uuid=03f42cda-00c5-40ea-9d58-2414a9932468, type={JBossAS7}Connection Factory, key=profile=full,subsystem=messaging,hornetq-server=default,connection-factory=RemoteConnectionFactory, name=RemoteConnectionFactory, parent=default]
	at org.rhq.core.pc.plugin.PluginComponentFactory.getResourceClassloader(PluginComponentFactory.java:213)
	at org.rhq.core.pc.inventory.InventoryManager.initResourceContainer(InventoryManager.java:1493)
	at org.rhq.core.pc.inventory.InventoryManager.processSyncInfo(InventoryManager.java:2626)
	at org.rhq.core.pc.inventory.InventoryManager.processSyncInfo(InventoryManager.java:2667)
	at org.rhq.core.pc.inventory.InventoryManager.processSyncInfo(InventoryManager.java:2667)
	at org.rhq.core.pc.inventory.InventoryManager.processSyncInfo(InventoryManager.java:2667)
	at org.rhq.core.pc.inventory.InventoryManager.processSyncInfo(InventoryManager.java:2667)
	at org.rhq.core.pc.inventory.InventoryManager.processSyncInfo(InventoryManager.java:2667)
	at org.rhq.core.pc.inventory.InventoryManager.synchInventory(InventoryManager.java:1085)
	at org.rhq.core.pc.inventory.InventoryManager.handleReport(InventoryManager.java:1059)
	at org.rhq.core.pc.inventory.InventoryManager.activateAndUpgradeResources(InventoryManager.java:2934)
	at org.rhq.core.pc.inventory.InventoryManager.initialize(InventoryManager.java:235)
	at org.rhq.core.pc.PluginContainer.startContainerService(PluginContainer.java:488)
	at org.rhq.core.pc.PluginContainer.initialize(PluginContainer.java:308)
	at org.rhq.enterprise.agent.AgentMain.startPluginContainer(AgentMain.java:1925)
	at org.rhq.enterprise.agent.AgentMain.start(AgentMain.java:659)
	at org.rhq.enterprise.agent.AgentMain.main(AgentMain.java:428)
Caused by: org.rhq.core.clientapi.agent.PluginContainerException: [Warning] Cannot load class [org.rhq.modules.plugins.jbossas7.SubsystemDiscovery] with null classloader
	at org.rhq.core.clientapi.agent.PluginContainerException.wrapIfNecessary(PluginContainerException.java:69)
	at org.rhq.core.clientapi.agent.PluginContainerException.<init>(PluginContainerException.java:96)
	... 17 more
Comment 1 Ian Springer 2012-05-15 12:18:18 EDT
After doing a full mvn clean install and restarting both my Server and my Agent, these errors no longer occurred. I'm closing it as NOTABUG. I'll reopen if I see it again with a freshly built environment.

Note You need to log in before you can comment on or make changes to this bug.