Bug 821916 - nfs-utils depends explicitly on libevent when it shouldn't
nfs-utils depends explicitly on libevent when it shouldn't
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
rawhide
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-15 14:28 EDT by Ross Lagerwall
Modified: 2012-09-25 11:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-25 11:25:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix it (539 bytes, patch)
2012-05-15 14:28 EDT, Ross Lagerwall
no flags Details | Diff

  None (edit)
Description Ross Lagerwall 2012-05-15 14:28:01 EDT
Created attachment 584760 [details]
patch to fix it

nfs-utils depends explicitly on libevent when it doesn't need to since the dependency on libevent-2.0.so.5 is picked up automatically.

The attached patch fixes this.
Comment 1 Steve Dickson 2012-09-25 11:25:53 EDT
(In reply to comment #0)
> Created attachment 584760 [details]
> patch to fix it
> 
> nfs-utils depends explicitly on libevent when it doesn't need to since the
> dependency on libevent-2.0.so.5 is picked up automatically.
> 
> The attached patch fixes this.

libevent is used by he rpc.idmapd daemon so it is needed...

Note You need to log in before you can comment on or make changes to this bug.