Bug 821919 - rhc tools require interactive input breaking cucumber tests
rhc tools require interactive input breaking cucumber tests
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-15 14:47 EDT by Rob Millner
Modified: 2015-05-14 21:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-08 13:58:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob Millner 2012-05-15 14:47:11 EDT
Description of problem:
Some cucumber tests use the rhc tools to create domains and applications.  A recent change causes them to stop and ask for interactive directions even if the tool has been given everything on the command line it needs to perform its task.

This causes domain and application creation to either fail or hang.


Version-Release number of selected component (if applicable):


How reproducible:
Always.


Steps to Reproduce:
1. cd /root/li-test/tests
2. cucumber trap-user.feature  (this will hang if done interactively)
3. in another terminal; examine /tmp/rhc/cartridge-php/cucumber.log
  
Actual results:

Either it will hang or you will get the following in the log file.

Starting Interactive Setup.

It looks like you've not used OpenShift Express on this machine before.  We'll
help get you setup with just a couple of questions.  You can skip this in the
future by copying your config's around:

    /root/.openshift/express.conf
    /root/.ssh/

https://openshift.redhat.com/ username: stty: standard input: Inappropriate ioctl for device



Expected results:
The domain and application are created non-interactively.


Additional info:

The proposed solution is to add a "--noninteractive" flag to the tools to prevent the wizard from running.
Comment 1 John (J5) Palmieri 2012-05-15 18:30:29 EDT
I just pushed a quick fix that restricts the wizard to only the rhc tool for now and adds a --noprompt flag.  I wanted to reserve the verbiage "interactive" for something like the git interactive tools if we ever wanted to add that.

As I reorg the code I will be cleaning this up a little more.
Comment 2 John (J5) Palmieri 2012-05-18 12:36:07 EDT
Fixed with default configs in rhc as well as the cucumber tests generating their own configs.
Comment 3 jizhao 2012-05-21 02:43:51 EDT
Verified on devenv_1782.

Note You need to log in before you can comment on or make changes to this bug.