Bug 821945 - 'ipa-client-install --uninstall' turns on nscd services unconditionally
'ipa-client-install --uninstall' turns on nscd services unconditionally
Status: CLOSED DUPLICATE of bug 985234
Product: freeIPA
Classification: Community
Component: ipa-client (Show other bugs)
2.1
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Rob Crittenden
Chandrasekar Kannan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-15 16:37 EDT by Robinson Tiemuqinke
Modified: 2015-01-04 18:52 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-22 07:13:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robinson Tiemuqinke 2012-05-15 16:37:46 EDT
Description of problem:

 When 'ipa-cient-install --uninstall' command is carried out, either runs directly on client side, or running on server side through 'ipa-server-install --uninstall', the nscd service is turned on all the time, don't consider whether nscd was running or not before converted into IPA client

Version-Release number of selected component (if applicable):

2.1.3-9 on redhat 6.2, could be on other platform as well.

How reproducible:
Every time

Steps to Reproduce:
1. Install a Linux 6.2 client, or other version client, then turn off nscd by 'chkconfig nscd off, service nscd stop'.

2. turn the node into IPA domain with 'ipa-client-install'

3. uninstall ipa client with 'ipa-client-install --uninstall'. check the nscd service and find that it is turned on. 
  
Actual results:

nscd is turned on by mistake.


Expected results:
nscd service should be kept off, or the same status before IPA client was installed.

Additional info:
Comment 1 Rob Crittenden 2012-05-22 10:44:55 EDT
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/2775
Comment 2 Martin Kosek 2013-11-22 07:13:03 EST
This is a duplicate of Bug 985234/https://fedorahosted.org/freeipa/ticket/3790

We will track the resolution there.

*** This bug has been marked as a duplicate of bug 985234 ***

Note You need to log in before you can comment on or make changes to this bug.