Bug 821958 - named crashes when a zone is deleted whose "Authoritative nameserver" is not resolvable.
named crashes when a zone is deleted whose "Authoritative nameserver" is not ...
Status: CLOSED DUPLICATE of bug 829353
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: bind-dyndb-ldap (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Adam Tkac
IDM QE LIST
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-15 17:13 EDT by Gowrishankar Rajaiyan
Modified: 2013-04-30 19:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-25 09:30:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gowrishankar Rajaiyan 2012-05-15 17:13:22 EDT
Description of problem:


Version-Release number of selected component (if applicable):
bind-9.8.2-0.9.rc1.el6.x86_64
bind-dyndb-ldap-1.1.0-0.9.b1.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Create a new zone and make sure that the "Authoritative nameserver" does not resolve to A or AAAA record.

[root@primenova ~]# ipa dnszone-add example.com
Authoritative nameserver: example.com          <<<<<<<<<<<<<<
Administrator e-mail address [hostmaster.example.com.]: 
  Zone name: example.com
  Authoritative nameserver: example.com.
  Administrator e-mail address: hostmaster.example.com.
  SOA serial: 2012051501
  SOA refresh: 3600
  SOA retry: 900
  SOA expire: 1209600
  SOA minimum: 3600
  Active zone: TRUE
  Dynamic update: FALSE
  Allow query: any;
  Allow transfer: none;
[root@primenova ~]#

2. Observe the following logs in /var/log/messages

The following messages are logged:
May 15 06:26:14 primenova named[6956]: zone example.com/IN: NS 'example.com' has no address records (A or AAAA)
May 15 06:26:14 primenova named[6956]: zone example.com/IN: not loaded due to errors.
May 15 06:26:44 primenova named[6956]: zone example.com/IN: NS 'example.com' has no address records (A or AAAA)
May 15 06:26:44 primenova named[6956]: zone example.com/IN: not loaded due to errors.

3. ipa dnszone-del example.com

4. Wait for few seconds.

Actual results:

May 15 08:27:44 primenova named[6956]: zone example.com/IN: not loaded due to errors.
May 15 08:28:14 primenova named[6956]: zone.c:11766: REQUIRE(zone->db != ((void *)0)) failed, back trace
May 15 08:28:14 primenova named[6956]: #0 0x7f7247b97c2f in ??
May 15 08:28:14 primenova named[6956]: #1 0x7f724654e89a in ??
May 15 08:28:14 primenova named[6956]: #2 0x7f72474be247 in ??
May 15 08:28:14 primenova named[6956]: #3 0x7f72474be281 in ??
May 15 08:28:14 primenova named[6956]: #4 0x7f72474be55a in ??
May 15 08:28:14 primenova named[6956]: #5 0x7f724121679b in ??
May 15 08:28:14 primenova named[6956]: #6 0x7f7241216e4b in ??
May 15 08:28:14 primenova named[6956]: #7 0x7f724121b4b6 in ??
May 15 08:28:14 primenova named[6956]: #8 0x7f724656d2f8 in ??
May 15 08:28:14 primenova named[6956]: #9 0x7f7245f22851 in ??
May 15 08:28:14 primenova named[6956]: #10 0x7f724548567d in ??
May 15 08:28:14 primenova named[6956]: exiting (due to assertion failure)
May 15 08:28:14 primenova abrt[13717]: /var/named/core.6956 fd(-1) is not a regular file with link count 1: Permission denied
May 15 08:28:15 primenova abrt[13717]: Saved core dump of pid 6956 (/usr/sbin/named) to /var/spool/abrt/ccpp-2012-05-15-08:28:14-6956 (93057024 bytes)
May 15 08:28:15 primenova abrtd: Directory 'ccpp-2012-05-15-08:28:14-6956' creation detected
May 15 08:28:15 primenova abrtd: Package 'bind' isn't signed with proper key
May 15 08:28:15 primenova abrtd: 'post-create' on '/var/spool/abrt/ccpp-2012-05-15-08:28:14-6956' exited with 1
May 15 08:28:15 primenova abrtd: Corrupted or bad directory /var/spool/abrt/ccpp-2012-05-15-08:28:14-6956, deleting


[root@primenova ~]# service named status
rndc: connect failed: 127.0.0.1#953: connection refused
named dead but pid file exists
[root@primenova ~]# 


Expected results: Should not crash.


Additional info:
Comment 2 Adam Tkac 2012-06-25 09:30:29 EDT

*** This bug has been marked as a duplicate of bug 829353 ***

Note You need to log in before you can comment on or make changes to this bug.