Bug 82200 - ntpd does not start after step ticker failed
Summary: ntpd does not start after step ticker failed
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ntp   
(Show other bugs)
Version: 8.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 85944 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-19 19:14 UTC by C. Ray Ng
Modified: 2007-04-18 16:50 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-10 11:20:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description C. Ray Ng 2003-01-19 19:14:56 UTC
Description of problem:
ntpd does not start after power outage because the ntp servers were not up yet.

Version-Release number of selected component (if applicable):
ntp-4.1.1a-9 on all RH8 systems.

How reproducible:
Always

Steps to Reproduce:
1. simulate power outage by stopping or disconnecting ntp servers
2. reboot or stop/start ntpd on any RH8 system 
3.
    
Actual results:
ntpdate failed in stepping with the tickers and quit starting ntpd.

Expected results:
ntpd should be restarted like all other previous versions, default to its
own local server and wait for the ntp servers that will soon be back on.

Additional info:

Comment 1 C. Ray Ng 2003-01-19 19:16:04 UTC
An suggested alternative in /etc/rc.d/init.d/ntpd might be

from:
        if [ -s "$ntpstep" ]; then
                ...
                [ ! $RETVAL -eq 0 ] && return $RETVAL
        else
                ...
                OPTIONS="$OPTIONS -g"
        fi

to:
        if [ -s "$ntpstep" ]; then
                ...
                [ ! $RETVAL -eq 0 ] && OPTIONS="$OPTIONS -g"
        else
                ...
                OPTIONS="$OPTIONS -g"
        fi



Comment 2 Harald Hoyer 2003-01-30 16:06:05 UTC
From the ChangeLog
* Fri Aug 23 2002 Jeremy Katz <katzj@redhat.com>
- service should fail to start ntpd if running ntpdate fails


Comment 4 C. Ray Ng 2003-01-30 18:31:28 UTC
Take a scenario of power outages, not unusual here in the Northeast, we have 
had three earier this month during the snow storm with freezing rain.

When the power comes back up, a farm of linux systems will boot itself up by
default using the RH configs. The ntp servers will normally take a few seconds 
or more to get its ntpd running. By then all linux systems running RH8 will
leave the ntpd off, other linux systems running prior version of RH8 were 
doing okay with ntpd started and waiting for the ntp servers to synchronize 
with.

The worst situation is that one did not notice this until much later when the
clock on those RH8 systems started to drift, authentication using Kerberos
started to fail, compiling codes using nfs server started to have time stamp
mismatch etc.

This behavior is inconsistent, as compare to other OS, like solaris, bsd, and
even older version of RH, and I certainly hope it is not a design feature.
Ntpd can be configured with a local server, 127.127.1.0, so it will start
even without remote servers, but it will elect one when they are available.

Beside the simple fix as previously suggested, other alternative could be to 
loop and wait for ntpdate to success, leaving ntpd off is not an option for
those who want to use ntp to keep accurate time.

Comment 5 Harald Hoyer 2003-02-10 11:20:26 UTC
fixed

Comment 6 Harald Hoyer 2003-03-11 12:01:33 UTC
*** Bug 85944 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.