Bug 822022 - [abrt] wallpapoz-0.6.2-1.fc17: xml_processing.py:77:__init__:AttributeError: 'module' object has no attribute 'expat'
[abrt] wallpapoz-0.6.2-1.fc17: xml_processing.py:77:__init__:AttributeError: ...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: wallpapoz (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mamoru TASAKA
Fedora Extras Quality Assurance
abrt_hash:b97937e4e16414ad4b096df77c1...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-16 01:56 EDT by Jefferson Elias
Modified: 2012-05-22 02:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-22 02:15:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
python -v /usr/bin/wallpapoz (19.64 KB, text/plain)
2012-05-21 02:17 EDT, Jefferson Elias
no flags Details
python -v -c "import xml.parsers.expat" (6.38 KB, text/plain)
2012-05-22 01:26 EDT, Jefferson Elias
no flags Details

  None (edit)
Description Jefferson Elias 2012-05-16 01:56:09 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
cmdline:        python /usr/libexec/daemon_wallpapoz
executable:     /usr/libexec/daemon_wallpapoz
kernel:         3.3.4-5.fc17.x86_64
time:           mer 16 mai 2012 07:51:41 CEST
uid:            1000
username:       jeff

backtrace:
:xml_processing.py:77:__init__:AttributeError: 'module' object has no attribute 'expat'
:
:Traceback (most recent call last):
:  File "/usr/libexec/daemon_wallpapoz", line 90, in <module>
:    wallpapozxml = XMLProcessing()
:  File "../share/wallpapoz/lib/xml_processing.py", line 77, in __init__
:    except xml.parsers.expat.ExpatError:
:AttributeError: 'module' object has no attribute 'expat'
:
:Local variables in innermost frame:
:wallpapoz_system: <wallpapoz_system.WallpapozSystem instance at 0x7f86ad5d5ef0>
:home: '/home/jeff'
:self: <xml_processing.XMLProcessing instance at 0x7f86ad81df38>

smolt_data:
:
:
:Général
:=================================
:UUID: fd05ba6f-9427-4548-b5a6-e169a69c9f3b
:SE: Fedora release 17 (Beefy Miracle)
:Niveau d'exécution par défaut: Unknown
:Langue: fr_BE.utf8
:Plateforme: x86_64
:BogoMIPS: 6184.58
:Fabricant du processeurs: GenuineIntel
:Modèle de processeur: Intel(R) Core(TM) i5-2400 CPU @ 3.10GHz
:Stepping du processeur: 7
:Famille de processeur: 6
:Modèle du processeur: 42
:Nombre de processeurs: 4
:Vitesse du processeur: 3101
:Mémoire du système: 3866
:Swap du système: 5887
:Fabricant: System manufacturer
:Système: System Product Name System Version
:Type d'ordinateur: Desktop
:Noyau: 3.3.4-5.fc17.x86_64
:SELinux activé: 0
:Stratégie SELinux: targeted
:SELinux strict: Unknown
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Périphériques
:=================================
:(32902:7260:4163:33869) pci, None, PCI/ISA, H61 Express Chipset Family LPC Controller
:(4332:33128:4163:33842) pci, r8169, ETHERNET, P8P67 Deluxe Motherboard [Realtek RTL8111E]
:(32902:258:4163:33869) pci, i915, VIDEO, 2nd Generation Core Processor Family Integrated Graphics Controller
:(32902:7190:4163:33869) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 4
:(32902:7184:4163:33869) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 1
:(32902:7186:4163:33869) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 2
:(4318:2661:4163:33588) pci, nouveau, VIDEO, EN210 SILENT
:(32902:7192:4163:33869) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 5
:(32902:7200:4163:33860) pci, snd_hda_intel, MULTIMEDIA, 6 Series/C200 Series Chipset Family High Definition Audio Controller
:(32902:7188:4163:33869) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 3
:(32902:7202:4163:33869) pci, i801_smbus, SERIAL, P8P67 Deluxe Motherboard
:(32902:7176:4163:33869) pci, ata_piix, STORAGE, 6 Series/C200 Series Chipset Family 2 port SATA IDE Controller
:(32902:7168:4163:33869) pci, ata_piix, STORAGE, 6 Series/C200 Series Chipset Family 4 port SATA IDE Controller
:(32902:7213:4163:33869) pci, ehci_hcd, USB, P8P67 Deluxe Motherboard
:(32902:7206:4163:33869) pci, ehci_hcd, USB, P8P67 Deluxe Motherboard
:(32902:256:4163:33869) pci, agpgart-intel, HOST/PCI, P8P67 Deluxe Motherboard
:(32902:7226:4163:33869) pci, None, SIMPLE, P8P67 Deluxe Motherboard
:(4318:3043:4163:33588) pci, snd_hda_intel, MULTIMEDIA, High Definition Audio Controller
:(6945:4162:4163:33928) pci, xhci_hcd, USB, ASM1042 SuperSpeed USB Host Controller
:(32902:257:4163:33869) pci, pcieport, PCI/PCI, Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port
:
:
:Informations sur le système de fichiers
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_si--w--sai49-lv_root / ext4 4096 4096 13092026 10122191 9991141 3276800 2969599 2969599
:/dev/sda3 /boot ext4 1024 1024 508745 404992 379392 128016 127701 127701
:/dev/mapper/vg_si--w--sai49-lv_home /home ext4 4096 4096 35161102 31827234 30066774 8806400 8746306 8746306
:/dev/sdb1 WITHHELD fuseblk 4096 4096 78141525 29991968 29991968 120098944 120017126 120017126
:
Comment 1 Mamoru TASAKA 2012-05-17 00:30:41 EDT
Well,
- would you have some idea when this issue happened?
- please attach ~/.wallpapoz/wallpapoz.xml when this issue happened (although the backtrace may suggest that your wallpapoz.xml is broken).
Comment 2 Mamoru TASAKA 2012-05-17 00:45:41 EDT
Also
- If this issue is reproducible (or if you are not sure), would you try
  $ python -v /usr/bin/wallpapoz
  and attach the whole output?
Comment 3 Jefferson Elias 2012-05-21 02:17:22 EDT
Created attachment 585731 [details]
python -v /usr/bin/wallpapoz
Comment 4 Jefferson Elias 2012-05-21 02:19:02 EDT
Sorry for being late.. i was off for some days.

I don't know what causes that issue which happens at startup.

Here is the content of wallpapoz.xml and as an attachment the result of your second answer.

Have a good day


more ~/.wallpapoz/wallpapoz.xml
<?xml version="1.0" encoding="utf-8"?><!DOCTYPE Wallpapoz><wallpapoz interval="5" random="0" style="2" type="workspace">
    <workspace name="rename this" no="1">
        <file>/usr/share/backgrounds/beefy-miracle/default/beefy-miracle.xml</file>
    </workspace>
    <workspace name="rename this" no="2">
        <file>/usr/share/backgrounds/beefy-miracle/default/beefy-miracle.xml</file>
    </workspace>
</wallpapoz>
Comment 5 Mamoru TASAKA 2012-05-21 21:38:57 EDT
Umm... it seems that your xml file itself is NOT broken, and I am unable to reproduce your issue.. So:

- Would you write what does the following command returns?
  a. rpm -q python python-libs
  b. rpm -V python python-libs

- Would you attach the full logs of the following command?
  python -v -c "import xml.parsers.expat"
Comment 6 Jefferson Elias 2012-05-22 01:26:35 EDT
Created attachment 585928 [details]
python -v -c "import xml.parsers.expat"
Comment 7 Jefferson Elias 2012-05-22 01:27:32 EDT
Hi ! 

I have attached the result of python -v -c "import xml.parsers.expat" 

Here are the results for :

a) rpm -q python python-libs
python-2.7.3-6.fc17.x86_64
python-libs-2.7.3-6.fc17.x86_64

b) rpm -V python python-libs
[NOTHING]
Comment 8 Mamoru TASAKA 2012-05-22 01:41:40 EDT
Thanks. Now one critical error is found, so:
would you show the output of the following?

* ldd -r /usr/lib64/python2.7/lib-dynload/pyexpat.so
* rpm -q expat
* rpm -V expat
* ldd -r /lib64/libexpat.so.1
* nm -D /lib64/libexpat.so.1 | grep XML_SetHashSalt
Comment 9 Jefferson Elias 2012-05-22 01:43:32 EDT
ldd -r /usr/lib64/python2.7/lib-dynload/pyexpat.so
	linux-vdso.so.1 =>  (0x00007fffa8bff000)
	libexpat.so.1 => /home/jeff/app/jeff/product/11.2.0/client_1/lib/libexpat.so.1 (0x00007f3bed42c000)
	libpython2.7.so.1.0 => /lib64/libpython2.7.so.1.0 (0x00007f3bed052000)
	libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f3bece36000)
	libc.so.6 => /lib64/libc.so.6 (0x00007f3beca7f000)
	libdl.so.2 => /lib64/libdl.so.2 (0x00007f3bec87a000)
	libutil.so.1 => /lib64/libutil.so.1 (0x00007f3bec677000)
	libm.so.6 => /lib64/libm.so.6 (0x00007f3bec37c000)
	/lib64/ld-linux-x86-64.so.2 (0x00000032f4200000)
undefined symbol: XML_SetHashSalt	(/usr/lib64/python2.7/lib-dynload/pyexpat.so)

rpm -q expat
expat-2.1.0-1.fc17.x86_64
expat-2.1.0-1.fc17.i686

rpm -V expat
prelink: /usr/bin/xmlwf: at least one of file's dependencies has changed since prelinking
S.?......    /usr/bin/xmlwf

ldd -r /lib64/libexpat.so.1
	linux-vdso.so.1 =>  (0x00007fff66bff000)
	libc.so.6 => /lib64/libc.so.6 (0x00000032f4600000)
	/lib64/ld-linux-x86-64.so.2 (0x00000032f4200000)
	
nm -D /lib64/libexpat.so.1 | grep XML_SetHashSalt
00000032fa20d9a0 T XML_SetHashSalt
Comment 10 Mamoru TASAKA 2012-05-22 02:15:24 EDT
(In reply to comment #9)
> ldd -r /usr/lib64/python2.7/lib-dynload/pyexpat.so
> 	linux-vdso.so.1 =>  (0x00007fffa8bff000)
> 	libexpat.so.1 =>
> /home/jeff/app/jeff/product/11.2.0/client_1/lib/libexpat.so.1
> (0x00007f3bed42c000)

Oh, so this libexpat.so.1 is not provided by Fedora's rpm. Perhaps you have installed some Oracle product (or maybe some other one) and have changed ld loader path (or have set LD_LIBRARY_PATH). I guess this (perhaps old) libexpat.so does not provide XML_SetHashSalt, which is the cause of this bug.

You may want to change ld loader path (or set LD_LIBRARY_PATH) only when you are really using the product you've manually installed, or you can try to remove /home/jeff/app/jeff/product/11.2.0/client_1/lib/libexpat.so.1 so that you always use libexpat.so.1 provided by Fedora's rpm.

Anyway this is not a bug of wallpapoz or not a bug in Fedora's python or expat, so once closing. Thank you for reporting the bug anyway.

Note You need to log in before you can comment on or make changes to this bug.