Bug 822060 - TicketMonster: Validation errors in JSDT
TicketMonster: Validation errors in JSDT
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: TicketMonster (Show other bugs)
2.0.0.ER5
Unspecified Unspecified
medium Severity medium
: CR2
: 2.1.0
Assigned To: Marek Novotny
Tomas Repel
ticket-monster
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-16 04:42 EDT by Karel Piwko
Modified: 2013-02-01 10:12 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-30 10:35:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBIDE-11652 Major Resolved Errors running builder 'JavaScript Validator' on project 'ticket-monster' 2013-12-12 01:28:32 EST

  None (edit)
Description Karel Piwko 2012-05-16 04:42:12 EDT
Description of problem:

Due to upstream Eclipse bug, JavaScript validator throws errors on the example.

Version-Release number of selected component (if applicable):

How reproducible:

Always.

Steps to Reproduce:
1. Import TicketMonster example
  
Actual results:

Validation errors.

Expected results:

No validation errors.

Additional info:

The workaround is to exclude specific JS files (jquery, jquery-mobile) from being validated.

Upstream fix: https://github.com/jboss/ticket-monster/commit/e65b1cd758c90b0808d7ff29928bfcfa77a844cb
Comment 1 Karel Piwko 2012-06-04 08:40:33 EDT
Tomas, can you please verify?
Comment 2 Tomas Repel 2012-06-05 09:10:56 EDT
The configuration file from upstream fix is not inside the WFK2 ER7 ticketmonster-demo.zip. The validation errors still arise when importing TM example.
Comment 4 Tomas Repel 2012-10-18 04:41:46 EDT
The file still missing in jboss-wfk-2.1.0-ER2-ticketmonser-demo.zip.
Comment 5 Marek Novotny 2012-10-18 04:49:13 EDT
OK, I get it, ticket monster assembly is excluding .settings directory by default
Comment 7 Tomas Repel 2012-11-07 10:54:22 EST
The file still missing in WFK 2.1.0.CR1 Ticket Monster example.
Comment 8 Tomas Repel 2012-11-08 04:46:46 EST
Status changed to ASSIGNED to conform the bugzilla workflow.
Comment 11 Vaclav Dedik 2012-11-12 08:20:57 EST
I modified the assembly.xml so that it includes .settings/.jsdtscope.
Comment 13 Tomas Repel 2012-11-15 09:05:04 EST
Verified in WFK 2.1.0.CR2.
Comment 14 Karel Piwko 2012-11-30 10:35:01 EST
Distributed as a part of WFK 2.1.0.GA release.

Note You need to log in before you can comment on or make changes to this bug.