Bug 822082 - Update lvm2 support for new thin-provisioning interface for 3.4 linux kernel
Update lvm2 support for new thin-provisioning interface for 3.4 linux kernel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Zdenek Kabelac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-16 05:55 EDT by Zdenek Kabelac
Modified: 2012-10-16 06:37 EDT (History)
12 users (show)

See Also:
Fixed In Version: lvm2-2.02.98-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-16 06:37:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Zdenek Kabelac 2012-05-16 05:55:20 EDT
Description of problem:

Since kernel interface for thinp has been extended (and is not backward compatible) libdm and lvm needs to be updated to reflect these changes.

New supported thin-pool flags in constructor:

ignore_discard
no_discard_passdown - currently with kernel 3.4-rc7 it has incompatible interface change, when device without discard support is being used.

New supported thin flags in constructor:

external origin dev


Version-Release number of selected component (if applicable):
2.02.95

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Zdenek Kabelac 2012-05-18 04:47:06 EDT
We have now proposal patch:

https://www.redhat.com/archives/dm-devel/2012-May/msg00161.html

Which would make things backward compatible.

But still we need to decide, what level of support lvm should provide here.

1. We could recalculate discard support for data device each time we manipulate with tables - and provide a proper option to the target constructor.
Since I'm unsure in which moment of the tree activation we are able to query device for discard support it may require to activate data device before thin-pool device in separate udev transaction and obtain information about discard support on this device.

2. We could ignore it - user will get error message in system log - but since there is low chance many user will be changing their discs with discard support.
In my case - I get to these problem since I use tmpfs as backend filesystem.
Once this patch: http://www.spinics.net/lists/linux-fsdevel/msg55155.html
goes upstream, it will eliminate use-case of discardless discs on my box.
But in this case if some device in the stack has really flipped its discard support condition, user will need to reactivate device to get the change propagate.
Comment 2 Zdenek Kabelac 2012-10-11 05:42:05 EDT
Upstreamed with some more following commits:

https://www.redhat.com/archives/lvm-devel/2012-August/msg00028.html
Comment 3 Peter Rajnoha 2012-10-16 06:37:35 EDT
The fix is included in lvm2-2.02.98-1.fc19.

Note You need to log in before you can comment on or make changes to this bug.