Bug 822091 - cheese-3.4.2 can't record videos
cheese-3.4.2 can't record videos
Status: CLOSED DUPLICATE of bug 815581
Product: Fedora
Classification: Fedora
Component: cheese (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-16 06:17 EDT by Alexander Volovics
Modified: 2012-06-06 06:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-06 06:41:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Volovics 2012-05-16 06:17:10 EDT
Description of problem:

I have a Z-Star 0ac8:c449 webcam in a Lenovo ThinkCentre Edge 91z.

It is recognized by the kernel (Fed17beta TC5) at boot:
[    9.453984] uvcvideo: Found UVC 1.00 device Integrated Camera
(0ac8:c449)
[    9.456016] usbcore: registered new interface driver uvcvideo

The gstreamer-properties video test works perfectly.

But when I use Cheese to record a video it doesn't work and I get
the following warnings:
** (cheese:1539): WARNING **: Could not get buffers from device
'/dev/video0'.
** (cheese:1539): WARNING **: Could not map buffers from device
'/dev/video0'
** (cheese:1539): WARNING **: Could not negotiate format

Taking pictures with cheese works OK.

Cheese-3.4.1 in Ubuntu-12.04 works perfectly with both pictures
and videos!


Version-Release number of selected component (if applicable):

cheese-3.4.2-1.fc17
kernel-3.3.4-5.fc17

How reproducible:

Allways

Steps to Reproduce:
1. Try to record video with cheese
2.
3.
  
Actual results:


Expected results:


Additional info:

I have the exact same problem on a Lenovo Thinkpad T520
with a Chicony Electronics webcam 04f2:b217
Comment 1 Hans de Goede 2012-06-06 06:14:05 EDT
Hi,

Can you please go to the preferences menu of cheese and see if the photo resolution and video resolution are set differently? And if they are can you please make the video resolution match the photo resolution?

Also make sure you've no other video programs open while you are trying this.

Thanks,

Hans
Comment 2 Hans de Goede 2012-06-06 06:41:20 EDT
Note this seems to be the same issue as bug 815581, so I'm going to mark this one as a duplicate. Please answer the question from comment #1 in a comment in 815581.

*** This bug has been marked as a duplicate of bug 815581 ***

Note You need to log in before you can comment on or make changes to this bug.