Bug 822114 - JON 3.1 Source bits seem unusually large
JON 3.1 Source bits seem unusually large
Status: CLOSED NOTABUG
Product: JBoss Operations Network
Classification: JBoss
Component: Installer (Show other bugs)
JON 3.1.0
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks: jon310-sprint11/rhq44-sprint11
  Show dependency treegraph
 
Reported: 2012-05-16 07:26 EDT by Mike Foley
Modified: 2012-05-17 10:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-17 10:44:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Foley 2012-05-16 07:26:24 EDT
Description of problem:  JON 3.1 Source bits seem unusually large 



https://brewweb.devel.redhat.com//archiveinfo?archiveID=208864

-------------------

From: "Chris O'Brien via RT" <release-engineering@redhat.com>
To: myarboro@redhat.com
Cc: mfoley@redhat.com
Sent: Tuesday, May 15, 2012 6:03:27 PM
Subject: [engineering.redhat.com #153385] Request push JON 3.1.Beta zips to CSP 

Ticket <URL: https://engineering.redhat.com/rt/Ticket/Display.html?id=153385 >

I was extremely surprised to learn that including a full clone of the git repository is actually a feature when building from a trusted SCM rather than an archive.

My suggestion would be to scrub the clone from the source zip. May I proceed with doing so?
Comment 1 Mike Foley 2012-05-16 07:49:34 EDT
<jsanda> i need to discuss with stefan but i think the size might be due to all of the history being kept when the svn repo was migrated over to git
Comment 2 Mike Foley 2012-05-16 09:36:25 EDT
Hi Mike,

This is a known problem and it's a consequence of how brew builds are done.  I've already talked about this with Mike Bonnet and it's not a simple thing to change.  However the src components produced by brew are not the ones that we attach for each JON release to the CSP so this is really a non-issue.  As described, here in step 11, we already have a script that generates the matching src components from the relevant JON tags used, usually 27MB in size: 
  JON 3.x build instructions:
http://jon01.mw.lab.eng.bos.redhat.com:8080/display/DEV/JON+3.x+Release+Builds#JON3.xReleaseBuilds-10%29PerformsmoketestingonthebuildandthenforwardtoQEforformalreleasetesting.

Typically JON GA/BETA artifacts pushed to CSP should look like the following as an example:
http://jon01.mw.lab.eng.bos.redhat.com:8042/dist/release/jon/3.0.1.GA/

-Simeon
Comment 3 Christopher O'Brien 2012-05-17 10:44:39 EDT
Obtained processed sources zip and moved forward with publishing it rather than the sources zip from MEAD.

Note You need to log in before you can comment on or make changes to this bug.