Bug 822115 - spacewalk-setup on CentOS Postgres not working
spacewalk-setup on CentOS Postgres not working
Status: CLOSED WORKSFORME
Product: Spacewalk
Classification: Community
Component: Installation (Show other bugs)
1.7
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Jan Pazdziora
Red Hat Satellite QA List
:
Depends On:
Blocks: space18
  Show dependency treegraph
 
Reported: 2012-05-16 07:30 EDT by daniel.gerne
Modified: 2012-11-01 12:23 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-16 12:46:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description daniel.gerne 2012-05-16 07:30:50 EDT
Description of problem:
The script has several issues. The documentation states that the only prerequisite is to have a database account having a password set. This misses that a database must exist (CREATE DATABASE xxx;). 

When I execute spacewalk-setup it will fail to populate db because there is no Language plpgsql. Therefore I switched to psql and created the language with 
CREATE LANGAUGE plpgsql;
Then i try again and this time the populate log will tell me 'relation xyz already exists'. I therefore delete the database and the language und recreate them. The next attempt I will get the 'no language plpgsql' error again (despite created as found in pg documentation)

Version-Release number of selected component (if applicable):
1.7

How reproducible:
https://fedorahosted.org/spacewalk/wiki/HowToInstall
  
Actual results:
Failed to populate database.

Expected results:
database populated.

Additional info:
I therefore think either there is a bug in 'spacewalk-setup' or the HowToInstall is missing some steps specific for postgres when it comes to the language.
Comment 1 Jan Pazdziora 2012-05-16 12:46:10 EDT
https://fedorahosted.org/spacewalk/wiki/HowToInstall#PostgreSQLPre-Requisites

In order to get Spacewalk to run with PostgreSQL database backend, you need PostgreSQL 8.4 server installed on the same or different machine. Use PostgreSQLServerSetup as a guide to get the server installed and setup. 

and the https://fedorahosted.org/spacewalk/wiki/PostgreSQLServerSetup gives step by step instructions, addressing all issues you mention.

Note You need to log in before you can comment on or make changes to this bug.