Bug 822117 - html2ps: "Use of assignment to $[ is deprecated"
html2ps: "Use of assignment to $[ is deprecated"
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: html2ps (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-16 07:46 EDT by Jonathan Kamens
Modified: 2012-05-29 06:36 EDT (History)
2 users (show)

See Also:
Fixed In Version: html2ps-1.0-0.9.b7.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-26 04:02:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2012-05-16 07:46:35 EDT
$ html2ps /dev/null > /dev/null
Use of assignment to $[ is deprecated at /usr/bin/html2ps line 3408.
$
Comment 1 Petr Pisar 2012-05-16 08:32:47 EDT
Thank you for the report. The usage of '$[' variable has been deprecated by Perl. The assignment to 0 what html2ps does is idempotent because the value is 0 by default. Simple removal of the line from html2ps should fix it without any side effects.

F18--16 are affected.
Comment 2 Petr Pisar 2012-05-16 09:06:04 EDT
Fixed as html2ps-1.0-0.9.b7.fc18 in F18.
Comment 3 Fedora Update System 2012-05-16 09:11:36 EDT
html2ps-1.0-0.9.b7.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/html2ps-1.0-0.9.b7.fc17
Comment 4 Fedora Update System 2012-05-16 09:11:57 EDT
html2ps-1.0-0.8.b7.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/html2ps-1.0-0.8.b7.fc16
Comment 5 Fedora Update System 2012-05-18 06:25:29 EDT
Package html2ps-1.0-0.8.b7.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing html2ps-1.0-0.8.b7.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8018/html2ps-1.0-0.8.b7.fc16
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-05-26 04:02:31 EDT
html2ps-1.0-0.9.b7.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2012-05-29 06:36:46 EDT
html2ps-1.0-0.8.b7.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.