Bug 822120 - rtl8192se: regression in linux kernel 3.3.5
rtl8192se: regression in linux kernel 3.3.5
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-16 07:56 EDT by Oleg Tsarev
Modified: 2012-06-22 04:37 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-26 18:24:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oleg Tsarev 2012-05-16 07:56:17 EDT
Description of problem:
After upgrade kernel to 3.3.5 my wi-fi doesn't work.
iwlist scanning works fine, show available networks, but network-manager can not connect any network.
I try to reboot back to 3.3.4 - on 3.3.4 all works fine.


Version-Release number of selected component (if applicable):
It is lines from dmesg:
[   11.085728] rtl8192se: rtl8192ce: FW Power Save off (module option)
[   11.085967] rtl8192se: Driver for Realtek RTL8192SE/RTL8191SE
[   11.085969] Loading firmware rtlwifi/rtl8192sefw.bin
oleg (0) /external/video$ sudo ethtool -i wlan0
driver: rtl8192se
version: 3.3.4-3.fc16.x86_64
firmware-version: N/A
bus-info: 0000:03:00.0
supports-statistics: no
supports-test: no
supports-eeprom-access: no
supports-register-dump: no
oleg (0) /external/video$ sudo iwconfig
em1       no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:"DIR-300NRU"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: B8:A3:86:BA:D6:48   
          Bit Rate=54 Mb/s   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr=2347 B   Fragment thr:off
          Encryption key:off
          Power Management:on
          Link Quality=70/70  Signal level=-35 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:168   Missed beacon:0

oleg (0) /external/video$

I also filled bug on kernel.org: https://bugzilla.kernel.org/show_bug.cgi?id=43253
Comment 1 Oleg Tsarev 2012-05-17 02:30:48 EDT
Please, freeze 3.3.4 version OR backport following patch:
https://bugzilla.kernel.org/show_bug.cgi?id=43253

Created an attachment (id=73319) [details]
Probable fix

This patch, which has just been merged with kernel 3.4-rc7+, fixes a racy
condition associated with asynchronous firmware loading. The main difference
for rtlwifi and friends between 3.3.4 and 3.3.5 is the switch from synchronous
to asynch. firmware loading that is necessary due to changes in udev.

This patch will be backported to 3.3.X, and may be in 3.3.6.
Comment 2 Josh Boyer 2012-05-17 09:37:26 EDT
This missed 3.3.6 but should be in 3.3.7.  We'll look at backporting it in the meantime.
Comment 3 Josh Boyer 2012-05-17 10:40:37 EDT
Oleg, could you test this scratch build when it completes:

http://koji.fedoraproject.org/koji/taskinfo?taskID=4083807

It contains a backport of that patch.
Comment 4 Oleg Tsarev 2012-05-17 11:28:58 EDT
Ok, will test and provide feedback.
Comment 5 Oleg Tsarev 2012-05-17 13:32:46 EDT
All works fine, thank you.

When 3.3.6 will be in the fedora 16? Or I should get fedora 17?
Comment 6 Josh Boyer 2012-05-17 13:42:14 EDT
(In reply to comment #5)
> All works fine, thank you.

Thanks for testing!  I've committed it to the fedora repository now.

> When 3.3.6 will be in the fedora 16? Or I should get fedora 17?

It was submitted as an update earlier, but the version submitted doesn't include this patch.  The bodhi update system will leave a comment in this bug when it is available in an updates repository.
Comment 7 Oleg Tsarev 2012-05-17 13:43:42 EDT
Thanks for your feedback and great quick job!

Will wait robot comment :)
Comment 8 Fedora Update System 2012-05-22 18:38:37 EDT
kernel-3.3.7-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.3.7-1.fc17
Comment 9 Fedora Update System 2012-05-22 18:39:50 EDT
kernel-3.3.7-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.3.7-1.fc16
Comment 10 Fedora Update System 2012-05-23 08:56:44 EDT
kernel-2.6.43.7-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.43.7-1.fc15
Comment 11 Fedora Update System 2012-05-24 11:36:04 EDT
Package kernel-3.3.7-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.3.7-1.fc17'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8314/kernel-3.3.7-1.fc17
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2012-05-26 18:24:20 EDT
kernel-3.3.7-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2012-05-26 21:50:07 EDT
kernel-3.3.7-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2012-06-04 20:33:44 EDT
kernel-2.6.43.8-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.43.8-1.fc15
Comment 15 Fedora Update System 2012-06-22 04:37:38 EDT
kernel-2.6.43.8-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.