Bug 822135 - loaders.ConcurrentLoadAndEvictTxTest.testEvictAndTx is failing for IBM JDK
loaders.ConcurrentLoadAndEvictTxTest.testEvictAndTx is failing for IBM JDK
Status: CLOSED DUPLICATE of bug 818863
Product: JBoss Data Grid 6
Classification: JBoss
Component: Infinispan (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tristan Tarrant
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-16 08:52 EDT by Tomas Sykora
Modified: 2012-08-15 10:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-16 16:11:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Sykora 2012-05-16 08:52:38 EDT
Description of problem:

Running Infinispan testsuite for JDG reveals problems with IBM JDK (this fails for both 6 and 7; and for RHEL5 and RHEL6 both 32 and 64 bit):

java version "1.7.0"
Java(TM) SE Runtime Environment (build pxi3270-20110827_01)
IBM J9 VM (build 2.6, JRE 1.7.0 Linux x86-32 20110810_88604 (JIT enabled, AOT enabled)

Hudson stacktraces:

https://hudson.qa.jboss.com/hudson/view/EDG6/view/EDG-REPORTS-FUNC/job/edg-60-infinispan-testsuite-rhel/38/jdk=ibm17,label=RHEL6_x86/testReport/org.infinispan.loaders/ConcurrentLoadAndEvictTxTest/testEvictAndTx/


This issue can be related to:
https://bugzilla.redhat.com/show_bug.cgi?id=818863 (need more investigation by manik)

ttarrant found out that IBM's and Sun's javadocs are different for LinkedHashMap.
Comment 1 Tristan Tarrant 2012-05-16 16:09:20 EDT
*** Bug 818863 has been marked as a duplicate of this bug. ***
Comment 2 Tristan Tarrant 2012-05-16 16:11:36 EDT

*** This bug has been marked as a duplicate of bug 818863 ***

Note You need to log in before you can comment on or make changes to this bug.