This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 822202 - Richfaces Kitchensink archetype - back button does not back to the correct page state
Richfaces Kitchensink archetype - back button does not back to the correct pa...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: Examples, RichFaces (Show other bugs)
2.0.0.ER6
All Linux
low Severity low
: CR1
: 2.1.0
Assigned To: Karel Piwko
Pavol Pitonak
rf-kitchensink
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-16 11:58 EDT by Juraj Huska
Modified: 2014-09-30 19:37 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-30 10:34:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker RF-12076 Minor Closed Kitchensink archetype - back button does not back to the correct page state 2013-06-04 16:33:55 EDT

  None (edit)
Description Juraj Huska 2012-05-16 11:58:23 EDT
Description of problem:
When clicking on the url of the freshly created new member (like /rest/members/0) and backing back from the xml viewing, results in removed freshly added member.
After refresh, or AJAX update (clicking on collapsiblePanel), the table is with all members again.

This happens only for freshly added members.

Version-Release number of selected component (if applicable):
Richfaces 4.2.1.Final

How reproducible:
On AS: JBoss AS 7.1.1.Final, EAP 6.0.0.ER3.

Steps to Reproduce:
1. Fill in correct data about member
2. Register him/her
3. Click on the REST url, generated for the particular added member
4. After loading new page, press browser back button
5. see that the new added member is not there
Comment 2 JBoss JIRA Server 2012-10-30 19:49:25 EDT
Brian Leathem <bleathem@gmail.com> made a comment on jira RF-12076

The problem is the browser is caching the page, and the ajax update doesn't refresh the cached copy of the page.  The solution is to disable caching for the page by manipulating the response headers:

{code}
response.addHeader("Pragma", "no-cache");
response.addHeader("Cache-Control", "no-cache");
{code}

This can be done in a ServletFilter, or in a JSF phase listener.
Comment 3 JBoss JIRA Server 2012-10-30 19:53:25 EDT
Brian Leathem <bleathem@gmail.com> made a comment on jira RF-12076

Implementing a filter or listener to disable the page cache will significantly increase the complexity of this example quickstart application without adding much benefit.

As an alternate solution, I propose setting the _target_ attribute of the REST link to open up the REST pages in a new window/tab.
Comment 4 JBoss JIRA Server 2012-10-30 19:56:51 EDT
Brian Leathem <bleathem@gmail.com> updated the status of jira RF-12076 to Resolved
Comment 5 JBoss JIRA Server 2012-10-30 19:56:51 EDT
Brian Leathem <bleathem@gmail.com> made a comment on jira RF-12076

Changed the REST links to open up in a new window
Comment 9 Karel Piwko 2012-11-30 10:34:02 EST
Distributed as a part of WFK 2.1.0.GA release.
Comment 10 JBoss JIRA Server 2012-12-19 13:15:33 EST
Juraj Húska <jhuska@redhat.com> updated the status of jira RF-12076 to Closed

Note You need to log in before you can comment on or make changes to this bug.