Bug 822209 - RichFaces kitchensink archetype - creating already registered user throws server side error - it should be caught and user should be noticed
RichFaces kitchensink archetype - creating already registered user throws ser...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: Examples, RichFaces (Show other bugs)
2.0.0.ER6
All All
low Severity low
: CR1
: 2.1.0
Assigned To: Brian Leathem
Pavol Pitonak
rf-kitchensink
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-16 12:09 EDT by Juraj Huska
Modified: 2014-09-30 19:37 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
project generated from kitchensink archetype
Last Closed: 2012-11-30 10:34:47 EST
Type: Enhancement
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker RF-12252 Minor Resolved kitchensink archetype - creating already registered user throws server side error - it should be caught and user should ... 2012-11-08 06:43:49 EST

  None (edit)
Description Juraj Huska 2012-05-16 12:09:13 EDT
Description of problem:
When creating an already registered user there is server side error, because of the not unique email:

javax.ejb.EJBException: javax.persistence.PersistenceException: org.hibernate.exception.ConstraintViolationException: Unique index or primary key violation: "CONSTRAINT_INDEX_8 ON PUBLIC.MEMBER(EMAIL)"; SQL statement:

There is also no error message rendered to the user. There should be some notice that such a user have been already registered.

Version-Release number of selected component (if applicable):
Richfaces 4.2.1.Final
Comment 1 JBoss JIRA Server 2012-05-31 04:55:11 EDT
Juraj Húska <jhuska@redhat.com> made a comment on jira RF-12252

I have created [this|https://github.com/jbossas/quickstart/issues/286] upstream issue.
Comment 2 JBoss JIRA Server 2012-05-31 04:56:12 EDT
Juraj Húska <jhuska@redhat.com> updated the status of jira RF-12252 to Resolved
Comment 3 JBoss JIRA Server 2012-05-31 04:56:17 EDT
Juraj Húska <jhuska@redhat.com> updated the status of jira RF-12252 to Closed
Comment 5 JBoss JIRA Server 2012-10-29 12:57:50 EDT
Brian Leathem <bleathem@gmail.com> updated the status of jira RF-12252 to Reopened
Comment 6 JBoss JIRA Server 2012-10-29 12:58:45 EDT
Brian Leathem <bleathem@gmail.com> made a comment on jira RF-12252

I have created the upstream issue: [jboss-as-quickstart/issues/286|https://github.com/jboss-jdf/jboss-as-quickstart/issues/286]
Comment 7 JBoss JIRA Server 2012-10-29 12:59:25 EDT
Brian Leathem <bleathem@gmail.com> made a comment on jira RF-12252

This issue has been resolved upstream, we'll have to pull that change into our quickstart.
Comment 8 JBoss JIRA Server 2012-10-30 19:38:14 EDT
Brian Leathem <bleathem@gmail.com> updated the status of jira RF-12252 to Resolved
Comment 9 JBoss JIRA Server 2012-10-30 19:38:14 EDT
Brian Leathem <bleathem@gmail.com> made a comment on jira RF-12252

This has been resolved with an upstream merge.
Comment 11 Karel Piwko 2012-11-30 10:34:47 EST
Distributed as a part of WFK 2.1.0.GA release.

Note You need to log in before you can comment on or make changes to this bug.