Bug 822229 - [RFE] Add system registration date to system.getDetails() function
[RFE] Add system registration date to system.getDetails() function
Status: CLOSED DUPLICATE of bug 645024
Product: Red Hat Network
Classification: Red Hat
Component: RHN/API (Show other bugs)
_unset
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: rhn-dev-list
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-16 13:41 EDT by John Villalovos
Modified: 2015-05-08 09:59 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-30 16:40:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Villalovos 2012-05-16 13:41:45 EDT
Currently I can not find any way to determine when a system was registered.  This information is present on the system's web page in RHN.

I have checked in both system.getDetails() and system.listSystemEvents() and so far no joy.

I suggest modifying system.getDetails() to provide this data:

Method: getDetails
Description:
Get system details.

Parameters:

    string sessionKey
    int serverId

Returns:

    struct (details)
        string "profile_name" - System's profile name
        string "description" - System description
        string "base_entitlement" - System's base entitlement label (enterprise_entitled or sw_mgr_entitled)
        boolean "auto_errata_update" - true if system has auto errata updates enabled
        boolean "location_aware_download" - true if system is allowed to get downloads based on location
        string "address1" - System's address line 1
        string "address2" - System's address line 2
        string "city"
        string "state"
        string "country"
        string "building"
        string "room"
        string "rack"

** NEW **
        string "registered_date" - Date that the system was first registered with RHN
Comment 1 Xixi 2014-06-30 16:40:00 EDT
This has been provided via Bug 645024 - [RFE] Provide method to get system's registered date via RHN Hosted
where a new API call was added (system.getRegistrationDate)

Closing as duplicate.

*** This bug has been marked as a duplicate of bug 645024 ***

Note You need to log in before you can comment on or make changes to this bug.