Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 822241 - filesystem flushing notifications show up when ejecting read-only optical media
filesystem flushing notifications show up when ejecting read-only optical media
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gvfs (Show other bugs)
17
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
RejectedNTH
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-16 15:22 EDT by Tim Flink
Modified: 2015-03-03 18:05 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-26 03:41:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
"writing data to $disk_name" notification (8.02 KB, image/png)
2012-05-16 15:22 EDT, Tim Flink
no flags Details
"You can now unplug $disk_name" notification (6.01 KB, image/png)
2012-05-16 15:23 EDT, Tim Flink
no flags Details

  None (edit)
Description Tim Flink 2012-05-16 15:22:32 EDT
Created attachment 585040 [details]
"writing data to $disk_name" notification

With the fix for rhbz#819492, there are some odd notifications which show up in gnome-shell when ejecting read-only optical media.

Builds Affected:
 - nautilus-3.4.2-4.fc17
 - udisks2-1.94.0-4.fc17
 - gvfs-1.12.3-1.fc17
 - gnome-shell-3.4.1-4.fc17

Process:
 - insert read-only DVD into optical drive
 - eject the DVD
 * "Writing Data to $disk_name don't unplug until finished" notification
 * "You can now unplug $disk_name" notification

Since it isn't possible to either unplug a read-only optical disk or write data to it, these notifications are out of place and shouldn't show up for this type of media.
Comment 1 Tim Flink 2012-05-16 15:23:14 EDT
Created attachment 585041 [details]
"You can now unplug $disk_name" notification
Comment 2 Fedora Update System 2012-05-16 17:51:03 EDT
nautilus-3.4.2-5.fc17, gnome-shell-3.4.1-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/nautilus-3.4.2-5.fc17,gnome-shell-3.4.1-5.fc17
Comment 3 Adam Williamson 2012-05-16 18:00:30 EDT
Proposing as NTH as it would be good to have this cleaned up since we're spinning RC2 anyway.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Robyn Bergeron 2012-05-16 18:16:07 EDT
+1 NTH
Comment 5 Tim Flink 2012-05-16 18:22:18 EDT
I tried the update from c2 and it no longer shows the notifications for optical media. Thanks for the really fast turnaround on this.

-1 NTH because it just looks bad. I can't really see this being an issue that can't be fixed with an update. Sure, someone running a liveusb might use an optical disk but it's just extra notifications that don't really harm anything.
Comment 6 Robyn Bergeron 2012-05-16 18:32:23 EDT
To elaborate on my +1 NTH: This is mostly from my perception that this would be ongoingly visible or concerning to people either (a) booting from a live dvd or (b) who don't get updates because they have no internet (though really, there are a lot of updates they won't get). 

As I now understand, this wouldn't happen in the live situation - so I think I can more safely say -1.
Comment 7 Kamil Páral 2012-05-17 04:23:28 EDT
I don't think this is important enough to introduce new untested builds. I agree with -1 NTH.
Comment 8 Adel Gadllah 2012-05-17 11:17:38 EDT
(In reply to comment #7)
> I don't think this is important enough to introduce new untested builds. I
> agree with -1 NTH.

There are not really untested ... we already have +2 karma and the code changes aren't really that scary.

So I'd say +1 NTH.
Comment 9 Fedora Update System 2012-05-17 18:56:40 EDT
Package nautilus-3.4.2-5.fc17, gnome-shell-3.4.1-5.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing nautilus-3.4.2-5.fc17 gnome-shell-3.4.1-5.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7977/nautilus-3.4.2-5.fc17,gnome-shell-3.4.1-5.fc17
then log in and leave karma (feedback).
Comment 10 Tim Flink 2012-05-18 17:26:47 EDT
Discussed in the 2012-05-18 blocker bug review meeting. Rejected as NTH for Fedora 17 final because while this looks bad, it is mostly an annoyance and users are unlikely to hit this using livemedia. Therefore, this bug could be fixed with an update and does not qualify for NTH status.
Comment 11 Fedora Update System 2012-05-26 03:41:42 EDT
nautilus-3.4.2-5.fc17, gnome-shell-3.4.1-5.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.